: Engine on or off during On Board Diagnostics?



ddias1
05-16-06, 11:56 PM
I am diagnosing my P071 code, and am wondering if, the engine should be running or not when t-shooting?

JimHare
05-17-06, 08:08 AM
What kind of troubleshooting do you mean? The engine is OFF (but Key in Start position) to retrieve the DIC codes, but after that? Not sure what you meant by 'troubleshooting'....

Night Wolf
05-17-06, 11:57 AM
to retrieve codes engine can be running or off.

Depending on the tests perfoming, you will want the engine either running, or off...

ddias1
05-17-06, 04:55 PM
I'm using the Alldata fualt tree for P071. It says to check the value of PD02 in the PCM data menu of the OBD. If the value is 20-85kPa then I have a bad MAP sensor. The value changes if the motor is running or not......

peteski
05-18-06, 01:28 AM
So, what is your question?

If you checked PD02 with the engine off, if should steadily indicate the barometric pressure where the car is at. I'm close to sea level, so I would expect something around 100-104kPa.

When the engine is running, the values you show sound right. When the car is idling, it should be close to the low range (20s). When you open up the throttle, the value will go up. So, if it showed 20-80 at various throttle settings, then the MAP sensor would be good.

Sounds like the Alldata fault tree is not all that well written...

Peteski

ddias1
05-18-06, 01:50 AM
Thanks for the reply peteski! Yeah, the AllData test is pretty vague. Right now at idle its at 33-34kPa. I'm below sea level, not really sure how much. Its about 95 degrees here. With the engine off, I'm reading about 101kpa. I cleared my codes and P071 keeps coming back...any other suggestions for testing the MAP sensor? What else could be causing this?

ddias1
05-18-06, 02:03 AM
I know this sounds out of left field, but could my battery be a cause?

peteski
05-20-06, 10:52 PM
You're below sea level!? Hmmm... Not many dry places are... :)

I also think that your readings look perfectly normal. If I remember, I'll check mine (on my 93 Eldo) next time I go driving.

Peteski

JimHare
05-22-06, 06:42 PM
You're below sea level!? Hmmm... Not many dry places are... :)

The ones in Death Valley are.. :) Fresno is nowhere near D/V but you can never tell with California..things shift around there a lot.. :):bouncy: :bouncy: :bouncy: :bouncy:

danbuc
05-23-06, 12:12 AM
Yeah, the AllData test is pretty vague.

They don't call it NoData for nothin':thumbsup:

peteski
05-24-06, 04:14 AM
Last night I've checked the PD02 in my 93 N* Eldo.

With engine off it read 102. With engine idling around 750RPM, it read 37. Of course when I stepped on the throttle, the reading changed (went up when acccelerating and even under 37 when decelerating).

Peteski