: AC Recharging Help



dboncio99
05-16-06, 11:53 AM
I am having trouble getting past my compressor disabled warning. I am trying to recharge a 95 SLS AC system. I have checked the forum and tried to clear codes etc but was not able to clear it. WHat is proper sequence to clear this code when refrigerant low message appears? :confused:

Ranger
05-16-06, 12:12 PM
HIGH FAN = yes and LOW FAN = no. After codes are displayed I think you will see "PCM?". Answer no to that and any other prompts til you see "CLEAR CODES?". Then answer yes.

dboncio99
05-16-06, 12:47 PM
OK, that is exactly what I did last night, but for some reason I still got the very low refrigerant error. I even had the recharge bottle in place and open hoping that it could help the system turn on. But I just get the error and the compressor will not come on. Any ideas?:confused:

Ranger
05-16-06, 07:45 PM
Codes must be cleared first. Then hook up the refrigerant can and hold it upside down to service as a liquid when the A/C is turned on. This should allow the compressor to draw in sufficient refrigerant before the low pressure switch trips again. Sounds as though you are doing it correctly. Are you sure you cleared the codes?

Loose screw
05-17-06, 02:37 AM
You could cheat and diconnect the low sensor wires and temporarilyshort the connection with a jump wire and see if the compressor will even run. If it does let it take the can and then reconnect the low sensor. Maybe your sensor is bad ? Or you may have a big leak some where so you will never have enough presure.

Do you have a gage to tell you what the presure you really do have in your system? If it is at 0 you may have a good sensor and a blown hose or seal. I would think getting the pressure up or bypassing the sensor temporarilywould allow the code to go to history and not stop the compressor from running. But I don't know that for sure - just a gusse but use a gage.

dboncio99
05-17-06, 06:36 PM
Well, I got through this last night. The code for the "very low refrigerant" is in the APC list and each seperate list, PCM, APC, TPC etc must be cleared individually, which now I know. Once I cleared this, the compressor came on and I could add the refridgerant no problem, Cold A/C again! THanks for the help!:thumbsup:

Ranger
05-17-06, 08:04 PM
Ah, that splaines it. On mine I get a CLEAR ALL CODES? prompt. I forgot that the older ones had to be cleared seperately. Glad you got it figured out.

rollman
05-22-06, 04:06 PM
Well, I got through this last night. The code for the "very low refrigerant" is in the APC list and each seperate list, PCM, APC, TPC etc must be cleared individually, which now I know. Once I cleared this, the compressor came on and I could add the refridgerant no problem, Cold A/C again! THanks for the help!:thumbsup:


Did you have to clear all codes in PCM , APC and TPC ? Before you could get the compressor to run ?

Ranger
05-22-06, 07:37 PM
I think the "Low Refrigerant" warning is a body code on the OBDI cars so you at least have to clear those.