: Rear Deck Lid



bxs144
04-29-06, 06:35 AM
How do you disconnect the rear deck lid from the trunk?? :confused: The guy tinting my windows doesn't want to leave a gap at the bottom of the rear window and says he can't get close enough without leaving a gap for light to shine in through. Also, does the rear pillars have air bags in them?? Just in case those get popped off to install the tint also. Thanks.

lasstss
04-29-06, 08:37 AM
How do you disconnect the rear deck lid from the trunk?? :confused: The guy tinting my windows doesn't want to leave a gap at the bottom of the rear window and says he can't get close enough without leaving a gap for light to shine in through. Also, does the rear pillars have air bags in them?? Just in case those get popped off to install the tint also. Thanks.

Sail panels have to come off, dont worry about the bags.
Might also be a few bolts to remove anong with the top portion of the back seat. Its a PIA but the right way to do it.

ChicagoCTS32
04-29-06, 09:58 AM
Your installer sucks :)... I got mine done without removing pillars or the rear deck and no gaps.

V-SATX
04-29-06, 10:20 AM
I tint all my vehicles and pay the small premium to the dealer for the lifetime warranty. Any problems with appearance and I take it back until they get it right.

bxs144
04-29-06, 10:24 AM
I want to get it right the first time and not have any problems like gaps on the edges. I do have a lifetime warrenty with the place and they have been in business for quite a few years.
I did find http://www.cadillacfaq.com/faq/answers/reardeck.html

nikon
04-29-06, 11:52 AM
yea, decklid is a PITA, one thing reed forgot to mention in the FAQ is that the decklid is basically glued of some sort around the back window, I did alot more work than I needed to because it didnt want to come out, then realized it was glued in there. Oh ya and your installer sucks, my guy did'nt remove anything and it look perfect.

ctsvett
04-29-06, 02:03 PM
nikon...

interesting.. mine was not glued... I wonder if the white clips were just holding yours in hard... could that be it or are you sure there was glue?

I have an 04 BTW... Could be model year..

Reed

nikon
04-29-06, 04:38 PM
nikon...

interesting.. mine was not glued... I wonder if the white clips were just holding yours in hard... could that be it or are you sure there was glue?

I have an 04 BTW... Could be model year..

Reed

oh it was glued, I took the white clip off before the deck came out...but your right it could be the model year.