: Wipers won't turn off!



My_favorite_Brougham
04-18-06, 09:35 PM
On my '90 Brougham, if you turn the windshield wipers on, they will work fine. But they will not turn off regardless of the swich position. You have to turn off the engine every time and jiggle the switch. Then they will be off when you restart. What's the issue?

DopeStar 156
04-18-06, 10:16 PM
Broken switch? Very easy to replace and find. Go junkyard hopping.

brougham
04-18-06, 11:38 PM
Are you pressing the washer button when that happens?

N0DIH
04-19-06, 02:59 AM
Sounds like the park motor isn't engaging and leaving them on waiting for it to come around to the park position.

When you select OFF, you should hear a click as the motor changes to get ready to park the wipers.

dill
04-19-06, 09:08 PM
85 brougham had problem not working posted 03.18.06 if the motors are the same u could have same problem, a broken printed circuit ,I also had that problem with my 87 brougham

dill

pimpin88
04-20-06, 10:23 PM
i had that problem, all i did was pull the plug that goes to the wiper motor, cleaned the contacts and plugged it back in.

has worked perfectly ever since

My_favorite_Brougham
04-20-06, 10:41 PM
Sometimes I have to press the washer just to keep the wipers from scratching the windshield, but I don't hear any clicking of the motor - It jumps from the on position to the single wipe, thus completely skipping the off position. Thanks.

gushue1234
05-25-06, 02:17 AM
I have a 1994 Eldorado. Mines been doing the same thing. I can hit the washer switch to turn the wipers on.(with the switch in the off position) or i can turn the switch to turn the wipers on. Either way the the wipers stay on until i turn my ignition off than on....resetting the computer im guessing. Anybody had this problem on a 94 or any caddy and actually fix it or know what the problem may be so i can fix it? Thanks