: need help again, new code



laurieH
01-18-04, 02:07 PM
Hi



Got my egr cleaned adn repaced and got the carb cleaning done. Two nights ago when I turned off my car in the garage I heard a noise. Sounded like someinthg was still running (like a fan or a belt whipping around) that is the soiund it made. It does it 50% of the time when I shut the engine off. Hve no iea what it is. Last igt I got my check engine ligt on aagain and the code is a PO30 I think that is heated oxygen sensor????? PLease someone tell me what this means and if this is the noise I am hearing. Hw do I fix this and whatever else you can add. I am pissed off right now that I have another probelm so quicly after he other are they related. I appreciate it I will check back on here in a bit .





laurie

Logandiagnostic
01-18-04, 03:34 PM
Its unrelated to the EGR code. The PO30 is for 'ISC out of range'. ISC is 'idle speed control'.

Its normal to hear some noise from the ISC at vehicle shut off. So some of that is normal. But...that being said.....the ISCs also can wear out. And the internal gears will make quite of bit of noise/popping sounds when worn out.

Being it sounds like the TB was just cleaned..it may require that simply the code needs to be cleared....or the ISC may need a slight adjustment. Or maybe a new ISC.

Logan
www.airbagcrash.com

laurieH
01-18-04, 06:33 PM
Thanks, I went on line and found that coe but cme up with something different. Where is the Idle control at??? is it hard to change out if needed???

A picture would be great if you had one of what it is, I like to at least see what I am looking for before I take it to a mechanic. Thanks.!!!!

Geno Castellano
01-19-04, 01:16 AM
Hi



Got my egr cleaned adn repaced and got the carb cleaning done. Two nights ago when I turned off my car in the garage I heard a noise. Sounded like someinthg was still running (like a fan or a belt whipping around) that is the soiund it made. It does it 50% of the time when I shut the engine off. Hve no iea what it is. Last igt I got my check engine ligt on aagain and the code is a PO30 I think that is heated oxygen sensor????? PLease someone tell me what this means and if this is the noise I am hearing. Hw do I fix this and whatever else you can add. I am pissed off right now that I have another probelm so quicly after he other are they related. I appreciate it I will check back on here in a bit .





laurie

The 30 is an idle speed control code. Before you do anything disconnect the negative battery terminal for 60 seconds or so to reset the idle learn offsets. If the throttle body was very dirty and the idle speed control routine had learned some very high offsets then it was trying to still use them when the throttle was being postioned when the key was turned off. Disconnecting the battery will reset the idle learn values which is where you want them to be (reset) with a clean throttle body.

Like Logan says it could be the idle speed control motor - but it would be highly unlikely that it failed at the same time you had the other work done unless they damaged it somehow.