: Speedometer Cable?



luddyludwick
04-11-06, 09:52 AM
Hi everyone,

Long time no post, but I haven't been driving the FWB much. However, when I totalled my daily driver a few weeks ago, that all changed!

In any case, I'm getting some pretty loud rattling noises that seem to be coming from speedometer area. I haven't pulled the dash yet because at my apartment the parking lot isn't a great place to work! I'll be back at home on Easter so that I can do some stuff, but just wondered if any of you have had trouble of this sort before. It seems only to appear around 70 mph on the highway.

Go figure, I just spent $400+ on new Michelins, and something else heads south...ahh well, it is 21 years old now...

Thanks for the help!

Bruce

N0DIH
04-11-06, 12:58 PM
Often the cable just needs to be greased.

You will need to pull the cable out from the dash side, so remove speedo cluster and pull cable, grease with white lithium and reinstall.

Same with cruise unit to trans. Pull from cruise unit side.

91sdv
04-11-06, 03:23 PM
NODIH is right.That cable, which is near the steering column, has to be taken out ,and re-greased. However, if you're going to do it yourself, and you have an airbag, disengage the battery first, so as not to accidentally set off the airbag.:confused:

N0DIH
04-11-06, 04:35 PM
Yup, disconnect battery (always a good idea messing with any steering column) and disconnect yellow connector under dash, make sure you are already grounded when you do, you don't want to blast the air bag off! Good catch 91sdv!

brougham
04-12-06, 12:55 AM
Since it's a 1985 he doesn't have to worry about having a air bag.

davesdeville
04-12-06, 02:41 AM
I've found it easier to do through the transmission side anyway on my old 78.

N0DIH
04-12-06, 12:55 PM
For some reason I thought he had a 90-91 car. Ooops....


Since it's a 1985 he doesn't have to worry about having a air bag.

I thought it wouldn't come out at the trans side, only working your way up. Been a while though. If you have cruise (which all Cads 77-up should), then you have 2 cables. Speedo to cruise, cruise to trans.


I've found it easier to do through the transmission side anyway on my old 78.

davesdeville
04-12-06, 09:52 PM
I don't think the cruise worked on my 78 (didn't care, didn't take it out of the city often) so now I'm thinking someone might've bypassed it with a cable between the trans and cluster. Hmm...

luddyludwick
04-12-06, 11:34 PM
Thanks everyone...

I'll check my shop manual again. Yes, 85 means no airbag. Also, it does have cruise, but being an HT car, I think it's mostly computerized, so is it possible that there is no cable? Sorry...too lazy to get out the manual tonight. Shop manual says you pull the whole left dash panel, but I was just hoping I could do the under-column trim panel...not going to happen since I have to get the speedo cluster out, I guess. I'll let you know how it goes.

Bruce

GenoTheLowrider
04-17-06, 10:47 PM
I am havin this same rattling noise on my 89, does this have anything to do with my cruise control not working?