: DANG - Trouble Codes Question



Pablo 94STS
03-24-06, 04:42 PM
Sorry guys.. I have looked and Googled, etc. and have not gotten to the bottom of my trouble code situation. Last night, the "service engine" light came on on my '94 STS. After about 50 miles, when I came to a stop, it was idleling real rough. Seems like the smell of unburned gas from exhaust, too.

Codes set are S044 (history), S030 (Current), P036 (history), and P071 (history). I have found conflicting code lists at various places on the net. I'm thinkin the P036 is EGR Valve Pintle Position out of Range.. whatever the hell that means.., and P071 Map Sensor ??

Any thoughts or advice would be greatly appreciated.

Are the codes for '94 Unique ??

fubar569
03-24-06, 04:52 PM
S030 ................................................ Speed Sensitive Steering Fault
S044 .................................................. ... Lift or Dive Signal Fault
P036 (E036) ................................. EGR Valve Pintle Position Out of Range
P071 (E071) ................................................ Intermittent MAP Signal

----------------------------

sounds like to me at some point the lift/dive sensor either failed or was aching up, causing the S030 and S044 codes.

P036 could also be caused as a result of P071 in a far fetched situation.

replace or inspect your MAP sensor and EGR, clear codes once done, and see if they return. the suspension codes i'm clueless on, but im willing to bet the sensor is faulty there as well...test it and replace if nessesary