: power sead won't work/1983 Coupe Deville



Benzilla
03-12-06, 09:56 PM
Its been like this ever since I bought the car, the seat is stuck all the way forward, and won't go back. when I push the switch it make it go: forward, up, tilt forward, I can hear the motor run. But when I try to make it go: back, down, tilt back, I hear nothing, and nothing happens. Whats wrong?

Benzilla
03-13-06, 12:37 AM
TTT by the way, I just noticed the typo haha. I ment power seat

taz600
03-13-06, 01:12 AM
try taking the switch out and cleaning it with rubbing alcohol

brougham
03-13-06, 01:59 PM
Either there's something wrong with the switch or some of the wires between the door and the car are broken. Get a different switch for it and see if that fixes it since it's easier then trying to find a broken wire.

CadillacMorgue
03-14-06, 10:12 AM
or try a new stea track..most of the time when you hear the motor its usually a bad transmission... when you hit the switch you hear the motor JA?
well then the switch is working, and you dont need a switch...

just the seat transmission ...

(1800 old junk )

brougham
03-14-06, 12:04 PM
Read his post again. He said for a lot of it he doesn't hear the motor at all. If he can hear it moving when he's trying to move the seat forward or whatever but nothings happening it's beause it already is all the way forward and it can't go anymore.

Benzilla
03-16-06, 09:28 PM
Yeah, Its already all the way forward, and when I move the switch to make it go forward I hear the motor running, but when I try to make it go back, I hear nothing and nothing happens. I'm not great at electric stuff, so I was going to have my local Cadillac dealer repair it. I just wanted to come on here and see if anybody knew for sure what was rong before I let some fatass grease monkey start rumaging around breaking stuff and then charge me $500 lol

Junkman
03-16-06, 10:45 PM
If you can hear the seat motor activate when the switch is moved into the forward position, but nothing happens when you try to move the seat into the reward position, then my guess is that there is a bad contact in the switch. It is rare that a wire will go bad on its own, and usually if it is a wire, then something had to happen to damage the wire. I would try spraying some TV/radio tuner cleaner into the switch and see if that helps. You can get the tuner cleaner at any Radio Shack. It is specifically designed for cleaning contacts and will do no harm to the switch. I would give that a try first before going to the dealer. Also, get a flashlight and make sure that the wires are firmly plugged into there connectors under the seat. The wire plug might have come partially unplugged.

If anyone reading this has a junk power seat transmission, I need the plastic shaft that goes to the motor to repair mine. Mine is a 1977, but I believe that they are alike for many years. I can also use some cables for a bench seat. Mine lived a hard life before I acquired it...