: AC/Heat Fan On but No Heat/AC



Caddy89
02-07-06, 10:16 PM
A while ago my battery was drained because the AC/Heat fan did not turn off after taking my key out. I unplugged the Fan wire in the hood to prevent my battery from being drained. Now when I do need any heat/ac/defrost fan power I would just connect the wire back to the terminal under the hood. It no longer works. I connect the fan, turn up my heat, but nothing comes out of the vents. I think the heat does work because my car does get warmer when the heat is cranked but it takes way too long (hour or more) or its very inifective without the fan blower.

Anyone else have this problem or know how to fix it?

Problem is on a 1982 Cadillac Fleetwood Brougham

Any suggestions would be greatly appreaciated,
Thanks,
Caddy89

carnut
02-08-06, 02:23 PM
The fan module, called the POWER MODULE is located passenger side in the large black heater box. Its on the top, the thick blower motor wire goes to it. its close to the hood hinge. That module controls fan speed and blower motor on/off function. When they short out the dash fan stays on. Replace the power module. Unplug the connector, remove the small screws and lift straight up and out.

Caddy89
02-09-06, 01:42 PM
Well, I before I remove the module I tried some more things.

I connected everything back up and ran it again.
-I only get fan blower movement out of the feet vents, nothing comes out of the "top" ones. All of them, nothing in the center, passanger or driver ports. There may be heat coming out of it, but as far as I know I can't feel it.

Blown fuse? Something cloging the vent? Please advise

Any idea why/what is causing this to happen?

Instead of getting a new module I'm thinking of temorarly running a circuit breaker into my car so I don't have to open the trunk everytime I want heat/ac.

Thanks again,
Caddy 89