: O2 Sensor still ????



NolaBoy
02-06-06, 05:10 PM
Alright a while back my Check engine light came on in my 99 Cat, got the code scanned and it came back as Oxygen Sensor 1 Bank 1. Before i could change it. a little thing happed called Hurricane Katrina(I live in New Orleans). Anyway being in the military we relocated our operations about 4 hours away. I bought a new sensor and changed it. Check engine light still on. Shortly after issues arose with the catera sputtering at startup which lead to a MAF sensor. I never got a code from the ecm leading to the MAF but through research on this board i figured that was the problem and changed the MAF sensor,that problem solved. Mind you the whole time i was getting the error code for the O2 sensor 1 Bank 1 and am still getting this code. So while i was changing the oil today i decided to look and see if i could see and loose, cut or frayed wires. I saw none. i unplugged the sensor to see if there were any issues with the connector. all appeared to be fine. What is the probability that this sensor may be bad. I am kind of at a loss here. I would hate to buy another sensor if something else is wrong, Any info you guys have would be greatly appreciated. The car runs perfect but i cant stand that annoying light :rant2:

NolaBoy
02-07-06, 10:19 PM
bump

NJ_Catera
02-08-06, 11:50 AM
I finally changed my O2 sensor because I got tired of the light too. I was told to drive the car 100 miles before getting it re-inspected. If you changed that sensor and driven over 100 miles, can you take it somewhere like Advance Auto and re-scan it or take it somewhere and have the check engine light reset?

rollingj1
02-11-06, 11:47 PM
You changed the sensor on bank1 followed by the MAF sensor. Not experienced with Catera and it is possible that the new sensor could be bad if it was exposed to coolant. I'm guessing that it is okay. What brand of O2 sensor did you use to replace the bad sensor? Do you know if the other front sensor would throw a different code if it had crapped out? Is it bank 0?