: High volt MAP



ghser7
02-02-06, 01:02 PM
I got both two different high volt Map sensor codes when I ran Diag. WOuld this be giving me shitty gas milage? I'm getting around 14mpg, not flooring it.

Should I change the Map sensor out?

ghser7
02-04-06, 11:25 AM
bump anyone?

Ranger
02-04-06, 11:55 AM
I thougt the Northstar went to MAF sensor around '95 or '96. If that is what you mean, yes I think it may be sending a bad signal to the PCM requesting a richer mixture. Have you checked the FPR?

ghser7
02-06-06, 08:34 AM
Well I'm getting these codes, but off and on.

DTC P0108 Manifold Absolute Pressure (MAP) Sensor Circuit High Voltage
DTC P1106 Manifold Absolute Pressure (MAP) Sensor Circuit Intermittent High Voltage

eldorado1
02-06-06, 12:25 PM
It's probably necessary to replace it. You can try unplugging it and plugging it back in...

Have you been experiencing any backfires in the past?

ghser7
02-06-06, 09:13 PM
not that I know of, but I'm gettin' shitty gas mileage.

Dadillac
02-06-06, 11:19 PM
When my MAP sensor went bad, the engine would bog at heavy acceleration. I would slam the pedal down, and the thing would act like a Yugo. After replacing the sensor, all is well again.

Don

ghser7
02-07-06, 05:07 PM
When my MAP sensor went bad, the engine would bog at heavy acceleration. I would slam the pedal down, and the thing would act like a Yugo. After replacing the sensor, all is well again.

Don

Well that sound like exactlly what I've got then. I thought it was the sensors in my tranny, b/c of the bogging. This is getting replaced as soon as i find where to buy one. Thanks Don!

eldorado1
02-07-06, 06:55 PM
Rockauto has them for $41 *41, sorry.

http://www.Rockauto.com