: 84 deville map sensor



ricorvair
01-19-06, 10:09 AM
I have a problem with the sensor in my 84 deville rwd. I can not trace the vacume line.

The computer gives code 34.

Autozone's computer said it was on the fenderwell. Not their.

The Haynes said it is sometimes under the dash. Found it there. But no vacume line was connected. If I put a hose on it and suck lightly the sensor light goes out.

I recently had the timing gear replaced.

Where does the line come into the passanger compartment.

Thanks to all.

The Ape Man
01-19-06, 11:40 AM
Look at the emissions sticker under the hood. The sticker is on the metal top radiator hold down plate neat the hood latch. It will help you trace the vacuum line form the throttlebody to the MAP sensor. You probably have found the BARO sensor in the dash. That gets hooked to nothing.

Katshot
01-19-06, 11:43 AM
As I recall, the MAP sensor IS under the dash. I seem to recall it being on the right side by the glove box. The vacuum line that goes to it is a fairly large black plastic line.

N0DIH
01-19-06, 12:57 PM
The baro sensor (looked like MAP) is under dash, I haven't seen a MAP under dash in non Cadillacs, but there is no reason not to really. Makes a cleaner engine compartment and protects the sensor from heat.

Katshot
01-19-06, 01:12 PM
There IS a problem with MAP sensor mounting where they were (under the dash). The problem was the fuel vapors in the MAP line would condense and flow "down-hill" to the MAP sensor and destroy it. We used to move them out into the engine compartment as a fix.

N0DIH
01-19-06, 01:17 PM
Never thought about that, hmm.... I guess GM found out the hard way....


There IS a problem with MAP sensor mounting where they were (under the dash). The problem was the fuel vapors in the MAP line would condense and flow "down-hill" to the MAP sensor and destroy it. We used to move them out into the engine compartment as a fix.