: problems with ignition coil after replacement ..



cadillac97
01-02-06, 06:36 PM
Before replacing ignition coil and wires, I had problem with rough idle, and it misfire on Cyl #1 & #4, took to the dealer and they scan that I need to replace ignition coil & wires 1 , 3, 5 cyl.
OK I bought the parts and replaced them, and after replacing them it seems that engine run fine, check engine was gone, until today, the same problem came back with rough idle and looks like I have no spark on cyl 1, 4,
now I am a bit suprised , what could of happen this time ?
I check the spark plugs and they are fine, I even switch with working cylinders and they do work, so it seems that this is related to electrical.
Why would coil failed already .. ? How can I check resistance on the coil ?
I measure the resistance on the coil that was originally in my car and check pin 1 2 3 & 4 and all shows 12 ohms on each pin.. I don't know if that is good or not..
pin 3 on coil is related to cyl 1 & 4 , what else is attched to pin 3 that could of make i fail already..

Thanks for any advice..

cadillac97
01-03-06, 09:55 PM
Add, to above post.. I have obtained electrical diagrams for the Ignition coil and how everything is wired up, and looking at the wiring diagrams it seems that pin 1, 2, 3 are wired directly to ECM and pin to ignition switch..
So the pin 3 is connected with cyl 1 & 4 on ignition coil, so if the code identifies misfire on the cylinder 1/4 could be related as well to ECM ?
Anybody might have some more info that maybe I can try to check this out ?
I am getting confused as why coil would fail after the replacement.. and I am running of options

cadillac97
01-05-06, 08:46 AM
update..
I have removed the coil I purchased and got tested, and it is dead on cyl 1/4 again, I have as well tested wires and wire for cyl #1 was bad, which probably was the cause of the failure of the coil, since the coil is under warranty I will get replace for another one, and ordered new wires for the car. I have as well tested wires between the coil and ECM and found problem with one wire for pin 3 which feeds power to ignition coil 1/4 I will replace the wire as well..

figgie
01-15-06, 06:02 PM
this is good news

do you have a diagram of the ECM pins? I need to check this on mine as mine did the same thing in chewing two coil packs.

cadillac97
01-16-06, 12:47 PM
I will post them later when will return from work..