: Speedometer stopped working on highway!!



liv2wrshp
12-23-05, 07:20 PM
Ok, the wierdest thing happened when I was on the highway last night. I was cruising along like normal when my tc and abs lights turned on. Immediately following, my speedometer went to zero. Then my check engine light came on. After a while, the tc and abs lights turned off and the gauge worked ok only to have it do it again 5 mins down the road. Any ideas?

miahcornell
12-26-05, 02:23 AM
not sure how the speedo in the catera works, but if its anything like the old style cable ones, it could be condensation/frost on the magnetic pickups behind the gauge.

bengsxr
12-26-05, 05:38 AM
http://www.cadillacforums.com/forums/showthread.php?t=58415 here is the reason why it is the module that needs to be replaced.

ewill3rd
12-26-05, 06:42 AM
Yep, the speedometer on Catera comes from the speed sensor reading on the right rear ABS sensor. If the EBCM takes a dive it won't send data to the ECM or the IPC on Vehicle speed. Your ABS/TCS lights should be on also and likely your check engine light too.
You need to get the EBCM replaced (brake control module) and I hope you are sitting down when they tell you how much it costs.
It's not really much of a DIY job either.
You need a handful of tools to reach into tight places. It's not very fun to replace.

ewill3rd
12-26-05, 06:44 AM
sorry.... computer glitch caused double post

Boris
12-26-05, 08:51 AM
Was it raining, snowing or really cold when it happened ???

Does the speedo work now ???

Before you replace anything I would inspect all electrical connections to the wheel sensor and the module.
Clean if necessary and apply some dielectric grease.
Check the fuses for corrosion and clean if necessary.
Leave the batteries ground disconnected over night and see if it does it again.

K.I.S.S.

You can always replace parts later but I would try the free things first.

ewill3rd
12-26-05, 10:34 AM
Actually boris, that's right.
It should be properly diagnosed to see if any outside influences are acting on this system.
There are as boris points out, many possibilities.

I didn't mean to jump to conclusions, you should have it checked to verified but to be frank, I have never seen anything that made a Catera speedo quit except for EBCM failure. That doesn't mean it couldn't be something else though.

Boris
12-26-05, 11:38 PM
ewill,
I'm not saying I'm right, all I'm saying is to eliminate all other possibilities.

The issues I have had with my electronics thus far have repaired them selves after I cleaned electrical connections and disconnected the battery to reset the system( disconnecting the battery a few times seams to fix just about everything):histeric:

The biggest problem I see with these cars is the fact that the US spec electronics were installed as an afterthought (or at least that's what it looks like) and they overcomplicated the whole situation.

With my '97 I replaced the main power and ground wires with 0 AWG (known as the big 3 on car audio sites) and have taken apart just about every electrical plug that I can get to.
All had signs of corrosion which I'm sure caused extra resistance.

Could that extra resistance be the culprit of many if not all the electronic malfunctions ???

liv2wrshp
12-27-05, 10:38 AM
K, I'll check that. It was just cold when it happened. No rain or snow. It goes back and forth now. It works then it doesn't. Tach never goes out though. It also feels like the power steering goes out at the same time. I'm going to autozone to get the codes though.

bengsxr
12-27-05, 10:45 AM
yes it does because these car have speed sensitive steering I am pretty sure at least this is true.

liv2wrshp
12-27-05, 03:20 PM
Ok, it came up with two different codes.

U2108 - Manufacturer specific DTC
P1700

Any ideas?

Thanks for your help guys. I love this forum.

bengsxr
12-27-05, 04:07 PM
P1700 is transmission control module
and U2108 is lost comm with ABS control system

ewill3rd
12-27-05, 05:13 PM
Yep, sounds like the EBCM is going bad.
The P1700 sets because the TCM loses VSS signal and tells the ECM to turn on the MIL.
The U2108 means the EBCM is not responding which is actually the source of the U1700 code like I just said.

pokerboy
02-22-06, 06:57 PM
i have the same problem in my 99 catera but my question is...is the ebcm bad even if it works sometimes? in my case it works when its very cold (chicago winter). i thought it might've been wiring but i dont know better any ideas? like i said my TC and ABS light is on most of the time and it goes away when its very cold ..weird!!!

pokerboy
02-22-06, 07:01 PM
i have the transmission light on as well ..i changed the TCM and it didnt do nothing ..maybe i have to do something else when replacing it like reset the codes i dunno any ideas??? do u guys think i have a wiring problem its a 99 catera

ewill3rd
02-24-06, 09:19 AM
This will also turn on the transmission light, because there is no Vehicle speed signal the TCM will set codes because it doesn't know how fast the car is going.
Need to replace the Brake control module.
EBCM

noturmomscaddy
03-20-06, 11:34 AM
This has happened to me and my '00 Catera at 111,000 mi. Anyone know where to get a used module?

ewill3rd
03-20-06, 03:18 PM
I have gotten some from salvage cars, but it's a crap shoot.
No guarantee that you won't go to all the trouble of installing it and have it do the same thing the next day or 6 months later.
I know the GM one is very expensive but at least it comes with a 12/12 warranty.

liv2wrshp
03-22-06, 09:17 AM
I got mine fixed at the dealership, but luckily I have a warrenty so I had to pay $100.

cattydrvr
03-30-06, 03:41 PM
Have any of you had the TC & Check engine light come on, after replacing the EBTCM? I cant figure what it could be...

zolee1
09-28-06, 12:26 PM
Hi I am having the same problem as most of you are having.
I have the ABS, TC, Check Engine Lights on. I am a little special because I also have the Water light on and just recently had my AirBag light come on. 

I have the following codes: U2108 twice, P0161, P1700.

I bought an EBTCM from a junk yard for about $150, replaced it. Now my speedometer works, but I still have the codes. My guess is that this EBTCM wasn’t good either.

I know that an EBTCM is around $1200, but you can get one from eBay, from a GM dealer for half the price. I am guessing that’s going to be my next step… I will keep you updated.