: Tail Light Problem... HELP..



rawdog805
12-20-05, 01:56 PM
Well I my entire passsenger side tail light is not lighting up... anyone know what this could be??? First it was the Back Up Light, but now all of a sudden the whole darn Tail Light is not lighting up.... any help..??

hcvone
12-20-05, 03:15 PM
Do the parking lights work on that light? Have you checked the bulb(s) ?

rawdog805
12-20-05, 07:15 PM
Do the parking lights work on that light? Have you checked the bulb(s) ?

No.. the parking lights dont come on or anything, just in that one tail light....

I tried switching bulbs, I went and got some 3157LL bulbs and that still did not work... do I need 3157K??? or are the 3157LL good??

99escalademan
12-20-05, 08:27 PM
i had the same problem on my 99. Switched the bulbs anmd nothing. Itr eneded up being the electronics plate that the bulbs plug into. DONT go to the dealer and pay 85$ . they have them on ebay , where i got mine for aound 30$.

slk230mb
12-20-05, 10:19 PM
Is there any water in the lense? I had some water in my lense and it shorted out two of the bulbs in my tail lamp. I replaced the bulbs but first i chaulked around the seal on the lense after it dried out. If it shorted out a lot of bulbs I would check for bad sockets and maybe a burnt fuse.

rawdog805
12-21-05, 01:11 AM
i had the same problem on my 99. Switched the bulbs anmd nothing. Itr eneded up being the electronics plate that the bulbs plug into. DONT go to the dealer and pay 85$ . they have them on ebay , where i got mine for aound 30$.

Thats exactly how much they quoted me to fix the problem.... Too bad they freaking failed my inspection... I am taking it to the dealer that I bought it from in the morning, so that they can fix it under my extended warranty and give me my darn inspection for free...

dnyce617
12-22-05, 10:02 AM
The circuit boards seem to be a common problem on the OBSs. I had the same thing when I had my 2000, and the dealer replaced it under warranty.