: couple of problems, only one code- AMP B1024



samm
11-30-05, 09:34 PM
I have been having some problems lately with my 99 SLS lately, with only one current code which is from the AMP, the code is B1024, loss of communications with DIM.

My problems are that when i am climbing up a hill- pretty much any incline, the acceleration of my car is jerky and not smooth. its very noticeable, too. it also does this when i accelerate hard, but not quite as noticeable.
Second, i just got a very annoying noise coming from the front of the passenger footspace, its like a humming/grinding/screeching noise. it is related to the fan of the climate control i believe because when i shut the CC off, the noise stops. Fan belt possibly?

Oh, i did forget to mention i had some codes on there before and i cleared them, so i can post them later when i get to my other computer. one was MAF range/performance or somthing of the sort.

Any help would be appreciated guys.
Thanks, SAM

zonie77
12-01-05, 01:54 AM
The rough acceleration is probably plug wires and/or plugs.

You can mist them with water from a spray bottle and see if you get a blue glow. You must be in a dark area to do this. Either at night or a darkened garage. The blue glow indicates arcing and bad wires.

samm
12-02-05, 12:11 AM
just spray them on the plug wires as they are?

1998Deville
12-02-05, 09:38 AM
Just wait till dark and thrun off all the lights including the under hood light if you have one. take a spray bottle and lightly spray the plug wires and see if there is a arc of electricity. You may see it without the water but since water conducts electricity it would make it more obvious. not a lot of water just a light mist. Don't grab the garden hose or anything! :bighead: