: P0171/p0174



shakushinnen
11-30-05, 08:27 PM
Hi,
My check engine light came on and I read these two codes. My understanding is that they mean, "System too lean Bank 1" and "System too lean Bank 2". If this is correct, can someone tell me what this means, and what I should do about it.
Thanks,
John

jebfrank
12-01-05, 11:53 AM
It could mean a couple of things, You could have a couple of faulty 02s, you could have a vaccum leak. How many miles are on your car? Does it idle fine?

shakushinnen
12-01-05, 01:54 PM
Hi Jeb,
There's about 60,000 miles on it. I should mention that the car has been running very rough when cold, for the past couple days. It hasn't stalled out but it seems like it wants to. Once it runs for a couple of minutes it's fine. The temperatures here is around freezing.
I have also had, what I think are, gas cap problems in the past. Could this be caused by a poor gas cap seal?
Thanks,
John

jebfrank
12-01-05, 10:36 PM
Humm, That is odd. I would rule out the gas cap. Some were there is unmetered air getting in there. Are all of your intake hoses tight and in place?Are all of your intake plentum bolts tight?
If that is not the case I have no clue, I bet it is something minor.

shakushinnen
12-02-05, 10:58 AM
Thanks Jeb,
I'll check those out. What, and where, are the "Plentum bolts"?
John

jebfrank
12-02-05, 11:13 PM
Under the black caps on the intake plenum. Good luck!!

shakushinnen
12-06-05, 11:33 AM
Under the black caps on the intake plenum. Good luck!!
Thanks Jeb...... John

bengsxr
12-07-05, 03:24 PM
you might want to give this a try unplug the mass air sensor and see what that does. cause it will go and you will have some problems

shakushinnen
12-07-05, 08:26 PM
Thank you all for your help. I took it to my mechanic this morning. He changed the fuel filter and flushed out the injectors. He also said that my code reader, the Innova 3100, read the wrong codes, that when he checked it P0174 and P0171 did not show up at all. I don't remember what the codes he got where.
John

ewill3rd
12-07-05, 09:46 PM
Rough idle on cold starts and lean codes on a Catera usually mean a bad MAF sensor.
They register an incorrect amount of air passing into the engine and cause this type of problem.

Hopefully yours is fixed. I don't think MAF sensors are cheap. I have replaced many for these very symptoms.

AllenPacla
12-08-05, 12:19 AM
MAF for the Catera is about $220.00. I replaced mine early this year. Got the part from GM Brasington

shakushinnen
12-08-05, 12:20 PM
Rough idle on cold starts and lean codes on a Catera usually mean a bad MAF sensor.
They register an incorrect amount of air passing into the engine and cause this type of problem.

Hopefully yours is fixed. I don't think MAF sensors are cheap. I have replaced many for these very symptoms.
Hi Ewill3rd,
Does clogged injectors also make sense?
John