: Strange happenings with my DIC



frank_rizzo
11-02-05, 03:51 PM
I had the strangest thing happen to me on my way home from work. My DIC went blank and then my welcome screen appeared and then the security message appeared (I forget the exact message but it has something to do with the security system).Then the security system and air bag icons came on. I might be crazy but the seat felt like it was getting warm even hot. I don’t have heated seats…

Has anyone experience similar problems like this ??? :bonkers:

MortnCyn
11-03-05, 06:22 AM
The DIC (aka radio) was replaced on our '04 about August of '04. It had the CD shuffle, clearing the trip odomters, etc. Had not had any more problems until about a week ago when we left early AM in the dark. The display on the DIC got very bright for a second or so and then the display as I recall looked like the following ---:--- Tried the change display that shows temp, tire pressures etc. and it did nothing. Turned on the radio and it worked OK. Still have some concern about the reliability of some '04 DIC's.

Kipp
11-03-05, 01:03 PM
I have the 05 and get the resetting trip od, fuel used and timer. The dealer will not swap it out because they state Cadillac has not corrected the problem.

louisn
11-04-05, 12:41 PM
I have the 05 and get the resetting trip od, fuel used and timer. The dealer will not swap it out because they state Cadillac has not corrected the problem.
Then why did my dealer swap mine out and I HAVE NO REOCCURRENCE OF THE GLITCH. THEY MUST HAVE CHANGED SOMETHING. Many 2004's have this problem. Usually the cd's also shuffle by themselves too. There is a service bulletin #05-08-44-002 which involves replacing the radio for these problems.
I

Kipp
11-04-05, 02:12 PM
When did u get the swap?

louisn
11-04-05, 09:42 PM
When did u get the swap?
JUNE 2005

Kipp
11-04-05, 11:04 PM
I went the beginning of Sept, with the TSB #. They said they spoke with cadillac on the matter. I believe them, they have been great towards my needs. Napelton Cadillac outside Chicago. I should give them a call for an update. Will post

robhersch
11-04-05, 11:49 PM
Re: 2005 Cad SRX V8 RWD, Bose, no nav (assy 12/04 delivered 1/21/05); I first noticed my DIC showing only yellow bars, CD "shuffling" with ignition off, and trip odometer/ average mileage "randomly resetting" - made notes when & where; took to my Fullerton, CA dealer on 7/28/05 with notes; dealer/ tech checked and said "special order replacement" - parts: 4557 Radio Internal Fault R0760-A 0.70 replace radio - ; dealer called me & scheduled for 8/5/05; I went & waited; replacement took ~ 1 hour; CD "shuffling" no more, trip odometer has not reset since; radio, CD, and DIC now performs as advertised

djfcars
11-05-05, 12:05 AM
Here's what my DIC has done wrong in the last two weeks-

1. Displayed only the border lines with no readouts.

2. Displayed "Check engine oil" and yes, the oil is full as I will say the V-8 does not burn a drop of oil so far.l


These two issues correct themselves when the car is restarted. SRX is a 2005.

My only problems with our car now and before, have been all about the DIC.

djfcars

ewill3rd
11-05-05, 07:58 AM
I have seen several similar complaints on CTS and a couple on SRX.
The ones I have replaced the radios in have not come back for those concerns. Your dealer can get a radio with the updates from Specmo.
The above mentioned bulletin does apply.

Your dealer may be hesitating due to an inability to duplicate the problem, they are probably dealing with technical assistance who likely want them to duplicate the problem before they replace the unit. Just keep politely bugging them and eventually they will replace the radio just to make you happy. Based on the complaints I see here it should fix your problems.

BTW I am assuming we are talking about the radio display, the base unit with the single CD or the CD changer, the one with the orange display.

I was reluctant at first to replace radios for this intermittent concern but I had a few customers that had repeat problems, now if the symptoms sound right I order one right away and reference this bulletin. I want my customers to be happy.
If you leave your car at the dealership, the replacements usually arrive overnight as long as parts are available. They might not want to give you a rental car for a radio since the vehicle is still drivable.

They also need to properly set up the radio when it's installed. To be sure the vehicle options are configured properly some flags have to be turned on when the unit is installed.

HTH

louisn
11-05-05, 09:08 AM
I have seen several similar complaints on CTS and a couple on SRX.
The ones I have replaced the radios in have not come back for those concerns. Your dealer can get a radio with the updates from Specmo.
The above mentioned bulletin does apply.

Your dealer may be hesitating due to an inability to duplicate the problem, they are probably dealing with technical assistance who likely want them to duplicate the problem before they replace the unit. Just keep politely bugging them and eventually they will replace the radio just to make you happy. Based on the complaints I see here it should fix your problems.

BTW I am assuming we are talking about the radio display, the base unit with the single CD or the CD changer, the one with the orange display.



HTH
Mine is the Bose with the 6 cd/changer that was replaced because of these problems; I think it was the upgraded unit since it was a $1000.00 option on the sticker.

ewill3rd
11-05-05, 10:16 AM
Affected radios are RPO codes U2R and U2S.
On SRX the SPID label that has all these RPO codes on them is located under the spare tire cover. The codes are listed alphabetically and the numbered codes at the bottom identify paint and trim codes.

Kipp
11-05-05, 09:26 PM
I have seen several similar complaints on CTS and a couple on SRX.
The ones I have replaced the radios in have not come back for those concerns. Your dealer can get a radio with the updates from Specmo.
The above mentioned bulletin does apply.

Your dealer may be hesitating due to an inability to duplicate the problem, they are probably dealing with technical assistance who likely want them to duplicate the problem before they replace the unit. Just keep politely bugging them and eventually they will replace the radio just to make you happy. Based on the complaints I see here it should fix your problems.

BTW I am assuming we are talking about the radio display, the base unit with the single CD or the CD changer, the one with the orange display.

I was reluctant at first to replace radios for this intermittent concern but I had a few customers that had repeat problems, now if the symptoms sound right I order one right away and reference this bulletin. I want my customers to be happy.
If you leave your car at the dealership, the replacements usually arrive overnight as long as parts are available. They might not want to give you a rental car for a radio since the vehicle is still drivable.

They also need to properly set up the radio when it's installed. To be sure the vehicle options are configured properly some flags have to be turned on when the unit is installed.

HTH

No mine has the NAV - Ill give them a call on Monday to remind them. Thanks for the info

ewill3rd
11-05-05, 09:48 PM
Kipp,

I haven't heard of these issues on a nav radio.
The only thing I see is a software update for some concerns that you did not note, so I doubt that will help your specific concerns.
Their concern is that they don't want to spend a bunch of money to have you end up with the same problem.
I'll keep my eyes peeled for a bulletin or any other info on nav radio concerns but I can't help you much more than that.

Kipp
11-06-05, 01:08 AM
Kipp,
I haven't heard of these issues on a nav radio.
The only thing I see is a software update for some concerns that you did not note, so I doubt that will help your specific concerns.
Their concern is that they don't want to spend a bunch of money to have you end up with the same problem.
I'll keep my eyes peeled for a bulletin or any other info on nav radio concerns but I can't help you much more than that.
Thanks again. They did a software update last time and wanted me to let them know if it fixed the problems. All it did was delete all my cotact info and waypoints stored in the nav. 05 n* production 09/04