: Anybody Have This Volant Problem?



rand49er
10-30-05, 04:45 PM
I debated whether to post this, but .. well ... here goes. After I installed my Volant CAI, the last step was to install the cover on the box (complete with my V emblem instead of the Volant emblem :yup: ). Well, the cover doesn't seal! Toward the front, it appears to be warped, and with only four fasteners to tie it down at the corners, there's a gap of about 1/4" or so between the cover and the mating surface of the box. I certainly don't recall that being the case when first removed it from the shipping box. I'm wondering if the two screws holding it to the radiator support, after being tightened, flexed the box a bit causing this. (They were one b!tch to get in!!) I ended up using weather stripping (yes, EVERYBODY has some of that laying around at this time of year here in Mich) to seal all around the the mating surface of the cover to the box. Seems to be okay, but I'm a bit chagrined to admit this was my "fix". Anybody else notice this problem?:annoyed:

04CTSVFLA
10-30-05, 05:41 PM
Im about to purchase one....any more info on this.

ALSO rand49er you notice any performance and hows the sound? Thanks....

I suggest u contact Volant...complain...if you do it nicely, mb theyll send you a new cover.

Blacksport350
10-30-05, 05:43 PM
Yup and I plan to fix it with some thin and sorta high-tech looking black weather strip. I don't think the front bolts warped the box, I just think the cover has a natural bow. I was also going to seal it to the fender intake when I got around to it.

ace996
10-30-05, 05:54 PM
Forget the stock cover...go to Home Depot and get a piece of plexiglass, cut to fit and then you can see the filter.
-my plan if I get the Volant

-ace

calicadi
10-30-05, 06:36 PM
No warped cover here. Doubt the box install could have caused it to warp, it's pretty sturdy. Is the lid now bowed? Check it on a flat surface. Maybe you can press it flat with a little strategically applied heat and weight?

51PHFTY
10-30-05, 07:06 PM
I just went out and looked at mine. At most, I have about a 1/16" gap on the long edge. Contact Volant, they may send you a new one?

Marty

rand49er
10-30-05, 08:58 PM
Im about to purchase one....any more info on this.

ALSO rand49er you notice any performance and hows the sound? Thanks....

I suggest u contact Volant...complain...if you do it nicely, mb theyll send you a new cover. It's not earth-shattering, but there seems to be a slight performance increase and some slight additional sound level/engine inhaling.

Staxxin
10-30-05, 09:02 PM
It's not earth-shattering, but there seems to be a slight performance increase and some slight additional sound level/engine inhaling.

I'm hoping for the same problem to occur....:D

rand49er
10-30-05, 09:02 PM
No warped cover here. Doubt the box install could have caused it to warp, it's pretty sturdy. Is the lid now bowed? Check it on a flat surface. Maybe you can press it flat with a little strategically applied heat and weight? You know, I didn't think of the lid being the problem, plus it's a whole lot easier to remove and check than the box ... I think I'll do that. Then, rather than contact Volant again (the technical support never did return my phone call when I called before ... great "support" that is :cookoo: ), I might just make that Home Depot trip.:highfive:

B Hoth
10-30-05, 09:08 PM
I think your on to something ACE. Put a clear fiberglass piece or maybe Lexan and then you would have a view of the blue filter. It would addd a nice bit of color to the engine compartment. My Volant should be here monday or tuesday. I'll look into it and keep you posted. I like it!!!!!

rand49er
10-31-05, 07:05 AM
My Volant should be here monday or tuesday. Say, BTW, check out calicadi's thread on the instructions as they may come in handy. Volant's "instructions" are woefully lacking.

CTSVONFIRE
10-31-05, 07:54 AM
I like ace's idea maybe get a little airbrush work done on the glass

Novi
11-09-05, 02:44 AM
I noticed the same thing after installing my volant so I called their tech support. According to tech support the bow is normal; it seals when the senor opens and air is sucked in.