: Serious engine problem??



84caddy
10-24-05, 07:50 PM
03 ESV - 6.0l - 60k miles - reg serviced at dealer since new

passing a transport a couple weeks ago (@5000rpm) the engine sounded like a stick was in the fan shroud...loss of engine power...as soon as I let off - it stopped...then everything ran fine

couple days later, same thing happened - this time I saw the check engine light flashing...but as soon as I backed off, it went away...continue normal day to day driving - no probs (but does feel a little "sluggish")

last week it happened again but this time the check engine light stayed on...called up Onstar, and they diagnosed "a PCM problem - get to a dealer asap". Other than the light - everything ran fine. Took it to a shop around the corner from where I work and they hooked it up and pulled a bunch of misfire codes - mostly #1. Changed plugs, wires, fuel filter...no difference. Oil pressure - perfect.

end of the day he says "you have a spun bearing"...the noise is causing the knock sensor to retard the timing which is giving you the loss of power. I don't believe him cause the engine runs fine until high rpm and the timing goes off...thinking that the misfire(s) is causing the noise that the knock sensor is hearing. He says fine - go get a 2nd opinion - but he's positive the engine is toast

so I pay and go to leave - now the truck can barely drive down the road! Idles fine, but will barely accelerate (bogs)...so I bring it back, we put it on the scanner - now its showing misfires on 1-3-5-7 ...the whole one side of the engine. Their explanation - "its getting worse"

anyway, been away at work since and haven't had a chance to have it towed for the 2nd opinion and its killin me.... I mean I've owned a ton of 4.1 Caddys so I know a knock when I hear it...this isn't making much sense to me!

any thoughts/ experiences?

slk230mb
10-24-05, 08:05 PM
If one whole bank of cylinders is mis-firing I would look at the ignition system. Check the coils, wires, and plugs for fowling. Also, with a spun bearing, I would expect oil pressure loss. Do you have an extended warranty by any chance? If so I would let the dealership take a look at it.

Falkolade
10-24-05, 08:42 PM
well... that sounds pretty bad since the motor has 60,000 miles on it... Thats why I like to get rid of mine after the warranty ends, because as much as we love our Escalades, we all know in the back of our minds they are not the most reliable trucks on the road. What did they say an engine replacement would cost? Good luck! ! !

84caddy
10-24-05, 11:08 PM
nah - didn't get the extended warranty...they quoted me about $10g's for a new crate motor installed

if it comes down to a swap - it'll be a 6 liter from a wrecker and we'll do it ourselves

but I agree - its gotta be an ignition problem...mis-firing on the whole side of the engine??

slk230mb
10-24-05, 11:25 PM
nah - didn't get the extended warranty...they quoted me about $10g's for a new crate motor installed

if it comes down to a swap - it'll be a 6 liter from a wrecker and we'll do it ourselves

but I agree - its gotta be an ignition problem...mis-firing on the whole side of the engine??

Damn, the engine and labor in our trucks is 10k :bonkers: I'd say to definatley get that second opinion.

Falkolade
10-25-05, 12:53 AM
10g... i'd be out for a second opinion VERY fast... install yourself??? now thats gotta be a challenge with new high tech stuff as opposed to low tech muscle car motors... Good luck keep us updated

84caddy
10-26-05, 04:13 PM
took it to another shop...diagnosis - 2 bad oxy sensors and a plugged LEFT cat

...things are looking UP!

84caddy
10-26-05, 04:16 PM
10g... i'd be out for a second opinion VERY fast... install yourself??? now thats gotta be a challenge with new high tech stuff as opposed to low tech muscle car motors... Good luck keep us updated

its pretty basic - we did a 02 yukon before...as long as its a straight swap (same engine/year)...hardest part is getting an engine hoist tall enough ...and labelling all the wires, etc

csmooth79
10-26-05, 04:16 PM
nah - didn't get the extended warranty...they quoted me about $10g's for a new crate motor installed


Stuff like this is making me want to skip a payment to get the gmpp warranty. Only 1 day remaining on my factory warranty.

slk230mb
10-26-05, 08:42 PM
took it to another shop...diagnosis - 2 bad oxy sensors and a plugged LEFT cat

...things are looking UP!

That sounds a lot more reasonable.

DenverEXT
10-27-05, 11:09 AM
When you have it fixed and running right, I'd go back to the original guy, show him the MUCH cheaper bill and tell him to stick it in his a$$. He's either ignorant or crooked. Either way it's something for the Better Busines Bureau.

danksontl
10-27-05, 06:34 PM
Before you buy a new cat, check your warranty. Cats are part of your emissions system and are usually covered longer than other areas on your vehicle. My experience with some dealers is that they won't tell you this unless you ask. Just a thought.

84caddy
10-28-05, 06:17 PM
picked up the truck today - replaced 2 bad oxy sensors and cat (under warranty) - runs like new :D