: Recommended fuel pressure + stalling



85Y
10-23-05, 03:40 PM
Having a lot of luck with the search function finding fuel pressure, but not on what the recommended fuel pressure is.

1997 DeVille.

Fuel pressure at idle is 42psi. Take the vac line off the regulator, it will sit at 42, then sparadically go up then down, then up to 50psi. On my other car, once you disconnected the line, FP would shoot up immediately. There was no fuel dripping out of the vacuum line or regulator. Who knows when the filter was last changed, so that's getting torn into when I get off work tonight.

This seems like it could be in the ballpark, but I am not quite sure without being able to get to the library to check AllData (which is closed on Sunday...grrr)

Also, I removed the FP relay with it running and the car died. According to this thread, it should have acted like a lot of other GMs and kept running (voltage fed through the oil pressure switch or sending unit, depending on the setup). http://www.cadillacforums.com/forums/showthread.php?t=47288&highlight=fuel+pressure

Why am I wondering?

The car runs and drives perfectly...I have only had it for 2 weeks and have put about 400 miles on it. Three times now, it has died out of the clear blue (electrical accessories still work). They were under 40 mph situations comming up to a stop. No problem starting it up again. Then a fourth time (which got me thinking it was fuel related) was when I started accelerating from a stop and the RPMs would not go over 2000rpm. It was like a rev limiter, and mashing down on the gas caused the Caddy to backfire through the intake. It ran like this for a minute. I pulled over and shut it off, waited 20 seconds, and started it up again. It has run perfectly since then. If the ignition module got hot, it would have taken much longer than 20 seconds for it to cool down. That time really ticked me off because it didn't throw ANY codes, even though I got it to backfire and I figured a half dozen misfire codes would show up.

Only code was P1599 or 1559, whichever meant engine stall or near stall detected.

If FP is normal, I guess my next shot is going to be looking at the troubleshooting charts on crank sensors.

TIA.

eldorado1
10-23-05, 06:06 PM
Fuel pressure should be about 40-45psi at idle, and raise 5 when you disconnect the vacuum line.

It sounds like you're on the right track. Replace the fuel filter because they're cheap and go bad after a bad tank of gas. Recheck the fuel pressure to see what happened.

If it still does the "up and down" after removing the vacuum line, it might be time to replace the FPR.

My guess is one of those will fix it. Not sure about the FP relay, that does sound kinda suspicious... But it's not causing your current problem.

Ranger
10-23-05, 06:14 PM
Fuel pressure, if memory serves me correctly is 45-50 psi but I would not expect stalling from 42 psi. Nor a backfire. Tape the fuel pressure guage to the windshield and watch the pressure when you accelerate, or more importantly, when the problem occurs. If it falls off greatly, then you have a fuel delivery problem.

How many miles on the car? Have you had the fuel rail recall done? I just sold my '97 Deville and I as well as many others have had misfire problems right after the work was done. It seems that moving those old wires around has some detrimental effect on them. New OEM plugs and wires curred the problem every time.

The engine dying is another story. Crank sensors would be a good suspect.

85Y
10-24-05, 06:40 AM
All my scanning software is OBDI so I can't log driving around to see what all my sensor values are. Also, my thinking was if my fuel pump was not getting full voltage (and there was not a restriction in the line, i.e. clogged filter, etc) then I could need to chase those wires. You are right--42 PSI would surely be enough to get required fuel to the injectors, but if there is a faulty connector at say the pump, I might have too much of a voltage drop from time to time.

Pressure tester only has a foot and a half long hose on it so routing it under a windshield wiper isn't going to be easy.

The only 'campaign' sticker I see is for the ABS/traction control. I still have the nylon fuel rails, so I will call up the dealer and see what the deal is. It was probably sitting on a used car lot around the time the recall was issued, guessing by this thread http://www.cadillacforums.com/forums/showthread.php?t=14083&page=2&highlight=fuel+recall

Reading through the various threads, a bad crank pos sensor seems more likely to be the culprit. Like I said, I don't have OBDII scan stuff yet, so I'll have to throw the portable o-scope on it and use the record function to see if I am losing signal.

Now I gotta actually hope it stalls. How weird...