: 94 SLS Smoked/Smelled and now Won't Start



haws
10-02-05, 11:53 PM
Pulled into the garage and turned off the key on my '94 SLS, but something kept running under the hood, like a pump or something. Not the fan. I tried restarting it and it wouldn't start. After about 4 or 5 minutes, I was removing a battery terminal to stop it, and there was some smoke and foul smell coming from the left side of the engine (Pass side) about mid engine. It stopped before I got the cable removed, but the car still won't start, turnover or notheing. Has plenty of juice. Anyone ever experience anything like this and if so, what was it?

mcowden
10-03-05, 12:51 AM
Pulled into the garage and turned off the key on my '94 SLS, but something kept running under the hood, like a pump or something. Not the fan. I tried restarting it and it wouldn't start. After about 4 or 5 minutes, I was removing a battery terminal to stop it, and there was some smoke and foul smell coming from the left side of the engine (Pass side) about mid engine. It stopped before I got the cable removed, but the car still won't start, turnover or notheing. Has plenty of juice. Anyone ever experience anything like this and if so, what was it?

It sounds like an idle speed control motor to me. If it's burned up and not letting enough air past the throttle blade, the engine will not start. Read the post at the very top of this forum "Got codes?" and go through that process. Let us know what you find in there and someone will probably be able to help you figure it out.

Have you ever cleaned the throttle body? If there was a bunch of gunk built up in there, it could have made the ISC motor's job harder and helped it burn up. The TB should be checked and/or cleaned about every 30k miles, but I check mine at every oil change because it's quick and easy.

A few thoughts to get you started. Let us know what the codes are.