: Tech question



Luna.
09-19-05, 03:56 PM
Here's another brain-stumper that I encountered yesterday...

Was humming on the freeway with the cruise control on. At one portion of this freeway, there are a couple of signals, then it returns to a normal freeway.

After I stopped, I attempted to resume my usual 80+ MPH travel when I notice that the car won't accelerate past 4k RPM. It was acting as it I was bouncing off the rev limiter!!!

I'm like, "WTF?" and proceed to turn-off the cruise control. Bingo--all of a sudden, it's running stronger than before...

Would this be a problem with the Mass Airflow sensor or just a silly computer malfunction or what?

RobzBLKV
09-19-05, 04:11 PM
You would think the outsourced the electronics of this car to Germany with the amount of quirky problems people are reporting. Maybe the cruise control is designed to stop at 4k? So the problem is the limited didn't shut off when you suspended the CC? Hmm. Going to have to test this on the way home tonight. Wonder if it always acts like that.

heavymetals
09-19-05, 04:36 PM
I think you have to be going a certain MPH before the cruise will take over.

Lindsay Cadillac
09-19-05, 04:46 PM
Here's another brain-stumper that I encountered yesterday...

Was humming on the freeway with the cruise control on. At one portion of this freeway, there are a couple of signals, then it returns to a normal freeway.

After I stopped, I attempted to resume my usual 80+ MPH travel when I notice that the car won't accelerate past 4k RPM. It was acting as it I was bouncing off the rev limiter!!!

I'm like, "WTF?" and proceed to turn-off the cruise control. Bingo--all of a sudden, it's running stronger than before...

Would this be a problem with the Mass Airflow sensor or just a silly computer malfunction or what?

Were you doing the accelerating or were you using the resume function of the cruise control??

Luna.
09-19-05, 05:18 PM
Were you doing the accelerating or were you using the resume function of the cruise control??

I was accelerating via the pedal (as normal). It just didn't want to accelerate past 4k RPM as it normally would.

NOTE--I have NOT been able to duplicate such, so my gut reaction is that it was something silly, but it still makes me raise an eyebrow...

Just very, very weird...

Lindsay Cadillac
09-19-05, 05:30 PM
Sounds like a "hiccup" in the throttle control system... We've seen the TAC module do all kinds of crazy stuff... I'd keep an eye on it and if it doesn't happen again then you're good... If it does act up then get it in to be checked out...


James