: "SERVICE VEHICLE SOON" in DIC wont go away HELP!!!!!!!



jimbohenson
09-12-05, 02:39 PM
Bought my 05 V in March of this year. Since then it has been in for service 6 times. I have had 2 radiators replaced due to seam leaks. The AC pressure sensor switch crapped out on the hottest day of the year. I have a "Service Vehicle Soon" message show up in the DIC intermittently. They have reprogrammed the ECU and the DIM (display information module). I just got it back Friday 9/9 and over the weekend I got the message four times. It is always at start up (cold or hot) never while driving. The message can be cleared. The car drives fine, no rough idle or anything. It is just a little embarassing when your passengers see this, to say the least. My dealer is great, Weil Cadillac/Hummer in Libertyville, IL, they come and get the vehicle and bring me whatever I want to drive. I am sending it back in today and requesting the ECU be replaced. Has anyone seen this issue?

urbanski
09-12-05, 02:45 PM
I found this on teh FAQ

Service Vehicle Soon Light comes on after 05 Alarm Activation
I had the same problem on my 05 V after having the alarm enabled by the local dealer. Took it back and they found that during the first reprogramming, they enabled another portion of the alarm system (intrusion sensor?) that does not exist on the V. Since it isn't present, the on-board computer periodically complains that it can't communicate with it. Dealer disabled this option through another reprogram and all is well now and my alarm works properly.

maybe they did that?
And the list of DTCs is here
http://www.cadillacfaq.com/faq/answers/dtccode.html

heavymetals
09-12-05, 05:07 PM
Same thing happened to me. The oil pressure SENSOR (not the switch located on the pan) was intermittant then finally failed.

I had "---" show up on the oil pressure display.

Three bars like a slot machine.:bonkers:

The display (DIC) changed to a car with a hood up and "SERVICE ENGINE SOON".

Could clear the display on startup.

If you have a maggie, the sensor is a bitch to get at, but can be done.:annoyed:

CTSVONFIRE
09-12-05, 06:13 PM
My v set's a lean code if I am in slow heavy traffic for about an hour or more. I think it's the aftermarket MAF. I have also had 1 new radiator, and a new rear diff.

GNSCOTT
09-12-05, 07:27 PM
Press the onstar button and ask them what code is being thrown.

lawfive
09-13-05, 03:08 AM
So, what message will we get when the DIC needs servicing?

ctsvett
09-13-05, 02:59 PM
So, what message will we get when the DIC needs servicing?


I hope you meant that as a joke.. reread that out of context and it sounds NASTY!
HAHAHAHAHAHAHAAH

Its almost as bad as "I found out what the banging in my rear end was" (<-- true topic thread from last week)

we are bunch of nasty f'ers

Reed

lawfive
09-13-05, 03:24 PM
No, Reed, I was in fact going for the "Service DIC Soon" message...

CVP33
09-13-05, 07:00 PM
My v set's a lean code if I am in slow heavy traffic for about an hour or more. I think it's the aftermarket MAF. I have also had 1 new radiator, and a new rear diff.

Why the new rear diff'? Just curious.

1fstkde
09-14-05, 04:32 PM
i have the same problem..right after they programmed my ecu, and activated my alarm, the same night the service engine light came on...took it back to the dealer and they said they took care of it, but that night same thing...i havent brought it back since..