: Most common problems with NS motor



DieselGuy
11-23-03, 06:49 PM
I am aware of the head gasket issue but have heard and read about several others.
But all have been from other wrenchs not owners of the NS motor. Mine has 114k and runs great I performed a block test before buying the car. Motor is free leak ( at this time) . Just looking for common things that gone wrong.

I work at a GM dealer so I plan on checking for updates and such but being that it is so old it may not be online on our system. Been to busy fixing those Dura max engines :annoyed: , To check for recalls.

I do not work on them very often ( cadillac)and when I do it is very minor things like brakes or some small trim items to get it ready for re-sale.

Thanks

AKPsiMC03
11-23-03, 06:54 PM
wait... whats wrong with the durmax motor. I have a friend who swears by them and i still think they are junk (i'm a ford guy by nature). but whats wrong with them?

on commom "problem" is the half-case seal leaking and the high oil consumption that GM claims in perfectly normal.

DieselGuy
11-23-03, 07:01 PM
wait... whats wrong with the durmax motor. I have a friend who swears by them and i still think they are junk (i'm a ford guy by nature). but whats wrong with them?

on commom "problem" is the half-case seal leaking and the high oil consumption that GM claims in perfectly normal.


They have injector woes, high oil usage :bonkers: Among the other dozen little things that go wrong. I get to work on them on a daily basis I would not take on if you gave it to me. It is better than the older model I guess... Dont get me wrong not starting a pissing contest with DM owners if there are ony here and you like them great,.... keep them. I too drive a ford truck a 03 SD 250 CC 4X4 with the PS motor. LOVE it no problems runs great, did I mention that it has been problem free?

Gm has some growing pains with it I hope they get it right fast, as warranty time SUCKS.


Back to my question any thing I should keep a eye out for??

N I C K E L
11-24-03, 12:37 AM
I am aware of the head gasket issue

what issue...

Robertsong
03-23-09, 01:08 PM
I am an owner of a 94 Concours w/4.6L Northstar, about 88K miles. MAP Sensor has been my problem. Running rough, engine cutout, had several codes, jotted them down, gave them to the mechanic, found exposed wires leading to the MAP sensor. BTW this sensor was replaced at 30K and 65K miles, with a complete ECU (is that right the engine computer) at 60K miles. After reading this forum I think that may have been a mistake, but then what do I know. I sure would like some help/advice anything regarding this MAP sensor. So I cleared the codes, drove about 100 miles, took the Customer Snapshot, and got a PO32, Open Map Sensor signal. Whazzup?
Other problems - really none. Oh yeah the oil leak. Fixed it with an $8.00 drip pan. Ride Sensing - oooh that was expensive. Read somewhere that the shocks cost $700, I was charged $1200 + labor each, with 2 replaced. Well I just replaced that shop!

Ranger
03-23-09, 03:31 PM
Why are you responding to a 5 year old thread?

EcSTSatic
03-24-09, 09:28 AM
Rip Van Winkle
http://www.john-howe.com/portfolio/gallery/data/media/8/037-Rip-Van-Winkle-port.jpg

Robertsong
03-30-09, 01:21 PM
Well EcSTStatic pretty much has it...I just woke...errr...Just found this forum, and being a green horned newbie, didn't even notice the date till too late. Which pretty much sums it up! But still the MAP sensor??? So now I have replaced it, and well, I am not getting the same codes, nor is the car running as rough. A bit of a "nervous" idle, and when there is any load (traffic going 45 or so heading up hill, hit the accelerator and it is a bit sluggish) but no more MAP codes. I am getting a couple, like I032, and a repeat of TO72. This again after I have cleared the codes, replaced the MAP sensor. Is this just something I am going to live with? Thing is I sold my 95 ETC, and only have the 94 Concours. I really love this car, and think I am lucky since I have the oil leak. I say that because I understand the alternative is an oil burner, right? Just had my seats re-done, and told the 'boss" its like having a new car. Getting ready for a road trip to Texas, and want to take "the big white one" instead of "Big Red" (a 2001 Yukon XL) The concours is soooo comfortable! The girls can sit in the back and admire themselves in the rear seat flip down mirrors! BTW anyone got a line on rebuilt AM/FM/CD/Cassette for this beast?
Does this all answer ur question?

MisterBlue
04-04-09, 02:42 PM
Things I've replaced in my N*...

Cam sensor
Crank sensor
Starter
Water pump
MAP sensor
O2 sensor

deepthinker22
04-09-09, 02:46 PM
wait... whats wrong with the durmax motor. I have a friend who swears by them and i still think they are junk (i'm a ford guy by nature). but whats wrong with them?

on commom "problem" is the half-case seal leaking and the high oil consumption that GM claims in perfectly normal.
A dirtymax?
1. It's not a cummins, Paccar, or detroit. Thats what is wrong. Though I do have a slight bias. ;)

CadillacCastle
04-12-09, 03:21 AM
I am an owner of a 94 Concours w/4.6L Northstar, about 88K miles. MAP Sensor has been my problem. Running rough, engine cutout, had several codes, jotted them down, gave them to the mechanic, found exposed wires leading to the MAP sensor. BTW this sensor was replaced at 30K and 65K miles, with a complete ECU (is that right the engine computer) at 60K miles. After reading this forum I think that may have been a mistake, but then what do I know. I sure would like some help/advice anything regarding this MAP sensor. So I cleared the codes, drove about 100 miles, took the Customer Snapshot, and got a PO32, Open Map Sensor signal. Whazzup?
Other problems - really none. Oh yeah the oil leak. Fixed it with an $8.00 drip pan. Ride Sensing - oooh that was expensive. Read somewhere that the shocks cost $700, I was charged $1200 + labor each, with 2 replaced. Well I just replaced that shop!

. Oh yeah the oil leak. Fixed it with an $8.00 drip pan. That is like fixing a leaking windshield by wearing a raincoat. LOL.