: New battery dead after just three days



ntechnic
09-04-05, 10:18 PM
After my V was found four mornings in a row with a stone cold dead battery, I jumped it and took it to the local dealer last Thursday. They installed a new Delco while I waited.

Oddly, the water temp gauge wasn't working, it showed "---" Thursday night and Friday, but then suddenly started working on Saturday. The anti-theft security system light (the one that looks like a padlock) was on half the time, I'd start the car and the light would be on and stay on, or I'd start it and it was off and fine--it never changed its status while the car was running.

Thursday and Friday the voltage was showing 14.1, lower than it used to, and lower than our SRX does (it shows 14.5 most of the time).

Then this morning, Sunday, stone dead battery again, not even enough light to make the interior lights glow dimly, stone cold dead again.

And of course, Monday being Labor Day, the dealer's service is closed. This time, instead of jumping it and driving it over there, I'm going to call Cadillac's roadside assistance and have them tow the car over to the dealership.

Has anyone had charging system problems?

GAGS-V
09-05-05, 01:48 AM
Be careful when they tow it. I'll bet you just got a bad battery! Good thing it's covered.

REDLINE_V
09-05-05, 09:04 AM
ntechnic,


I have the identical problem.I noticed you have a StealthV tune ....EMAIL me at mapconn@lycos.com

BliTzer
09-05-05, 09:29 AM
yeah i had same damn problem.. my voltage wouls show 13.5 to 14.1 when i finally got heavey duty delco from dealer in Texas, they said there was an entire bad batch of batteries, im not certain on how many that would be, could hundreds..

anyway i went thru 4 before i told them give me the best heavy duty they got at cadillac.. they did. no more problems... also i bought i batter tender from deltran. They are great,, when i go on trips and i know it will be at least 10 days or longer i plud it in... it is simple, comes with an quik adapter that goes on battery, then pull it in garage, plug it into deltran unit.. takes less than 5 min.

later blitzer

ntechnic
09-05-05, 08:02 PM
These batteries are dying in just 12 hours of sitting. I have a battery tender, I don't want to have to hook it up every single night, I want the problem fixed. Plus, what if I need to park overnight somewhere other than my house?

Art138
09-05-05, 08:49 PM
Come on 4 dead batteries! The first V I picked had the problem and they changed the battery only to realize it SB #04-06-03-003. A bad run of the "dash integration Module to cycle between active and inactive waking up other modules on the class 2 data line causing the vehicle to ramin active". That's what the service bullentin reads. The service bullentin also states " the scan tool will not indicate that the switch is active." So many techs without the knowledge of this problem will replace with another battery. Tell the dealer you want this module changed.

waswas
09-05-05, 09:44 PM
In my similar case we never got to the point of installing the new antenna module (though we had ordered it).
It turnd out that the "dimmer" slider on the overhead center console was not fully off....you have to fell a bit of "indent" when turning it off....so once that constant battery drain was corrected I have had no more trouble..

1MEANV
09-05-05, 10:25 PM
i had a bad battery also. they replaced it. sometimes my security light still comes on but o well. i jsut reset the computerand it is gone

BliTzer
09-05-05, 11:13 PM
I have a battery tender, I don't want to have to hook it up every single night, I want the problem fixed.

I understand that & i just fixed mine with a new battery. WHAT I SAID was, when I leave for a TRIP that will be LONGER than 10 days, i hook mine up to keep battery alive & to trick battery into thinking it is being used & trckle charged over again.. I did not mean to use tender to solve your problem. I had dealer put in a HEAVy Duty battery in mine to solve my dead battery problems... I have been thru bunches of them, now i have had the same battery for months. read my first post again to see what happened to me.

later blitzer

ntechnic
09-06-05, 12:27 AM
WHAT I SAID was My bad, I was in a bad mood when I posted, I have spent all of my Labor Day holiday upgrading and debugging my office server...

Actually, the car is on the tender now.

BliTzer
09-06-05, 12:33 AM
Its all good brother... i hope you get it right.. it can be very frustrating.. all the mods i have, i get to where i cross my fingers now before i even turn the key.. lol and thats not cause of the battery, thats hoping i will not hear something break.. so far so good.. the cross finger thing is working so far.. ;)

goodluck bro.. give hell at dealer, like i did.. telll them yoyu want a upgraded version for the battery, they gave me one that came out of one of there new HD trucks..

later blitzer