: OBD2 Code RSM0038???



jtauber
08-21-05, 04:55 PM
2 days ago the 96 Deville wouldn't start in Park, but would start in Neutral.

Yesterday, I drive to Sears Automotive to have the battery checked. Sure enough, bad battery, so I replaced it. A happy ending...or so I thought.

Today, no start. OBD2 codes say RSM0038. Problem:can't find this code after searching this forum and Google.

Anyone know what this code means? Any other thoughts?

Mucho thanks in advance.

mcowden
08-21-05, 05:50 PM
The RS0038 code means your electronic level control vent solenoid is shorted. It's probably rusted internally. Seems to be a fairly common problem. You will need to replace at least the solenoid, but I think it's part of the whole pump unit. You can try to replace the fuse. It's in the fuse panel behind the back seats, accessible by removing the carpet covering the seats in the trunk. The fuse is labeled either ELC or ALC. If you replace it and it pops again very quickly, which it probably will, replace the pump. It's above the rear axle on the passenger side. Disconnect a few wires, remove about 4-6 bolts to free it, then fish it out from its hiding place. You may need to take the mounting bracket off the old one and put it on the new one. You'll understand how to do that when you see it. New pumps are not cheap. The drier tube should be replaced at the same time. The whole assembly together costs about $400-$600 but you might be able to find a used one at a salvage yard. That's what I did and I paid $100 for it. I have read that before you put it all back together, you should take the plastic air hoses off the shocks and blow them out with dry air to make sure there is no water in the system. Also ensure the lines are intact and not cracked. If there is something wrong with the lines or where they connect to either the shocks or the pump, that must be fixed before you put it all back together or you're wasting your time. Some people prefer to change the lines regardless just to be sure. I have never done that, so I don't know how much the lines cost or how to do it.

Hopefully that's what you need to know. If you have any other questions, I'll do my best to answer, or you could ask in the Suspension forum. Whatever you do, let us know what work is done and how it turns out. Good luck!

jtauber
08-21-05, 09:32 PM
mcowden

thanks for your helpful reply. actually i had some rear suspension work done by local mechanic 2 years ago.
the autoleveling sensor wasn't working so he provided an inexpensive workaround, which likely accounts for this code.

considering this, i'm hopeful the problem is a short, alternator, or starter. when i get the problem diagnosed and fixed, i'll include the results here as reference for future searchers.

again, i really appreciate your help.

jtauber
08-22-05, 09:04 PM
and the answer is ... starter!