: New member Old Caddy



longhardride
08-14-05, 11:53 PM
Just thought I stop in here and say hello. I recently aquired a 84 Seville Elegante (bussel back i think is what its called) with 28,960 miles on it. The car belonged to my boss' father and when he passed away the car has pretty much just sat. Unfortunately the past couple of years it sat outside and the paint on the hood, top, and trunk lid has seen better days. Someone also bashed out the driver side window (replaced that, wasn't as difficult as I thought it'd be), so the lower seating area on the drivers side is has seen better days. Other than that the car is in really great shape.

Radio doesn't work, and I've had some trouble getting an aftermarket CD player installed. :mad2: Not familiar with Bose specs/requirements.

Plan on making it my DD. Should be able to make a decent ride out of her.

Boombotz
08-16-05, 11:22 PM
:welcome: to the forums. Good luck with the Caddy.

D148L0
08-17-05, 11:04 AM
Welcome to the forums.

Leloz
08-17-05, 11:37 AM
Welcome! From my experience with the Bose systems in several cars, you must get the entire system rewired from headunit to speakers. The Bose system uses separate amplifiers for the headunit and each speaker.

longhardride
08-17-05, 12:57 PM
Thanks!

Actually I was able to get my stereo issue resolved. Here's a link to that thread http://cadillacforums.com/forums/showthread.php?t=48770

addison_ii
08-17-05, 04:51 PM
Welcome longhardride, glad to hear you got your stereo problems fixed. Congrats on the purchase BTW. Post some pics when you get a chance.

longhardride
08-17-05, 08:12 PM
I put up a single page on cardomain.com just to put up some info/updates as well as pics. This is the only pic up now, and I'll try to post some more to it this weekend.

http://memimage.cardomain.net/member_images/11/web/2075000-2075999/2075791_2.jpg

Here's the link to my page http://www.cardomain.com/ride/2075791/1 (My 84 Seville)

I looked but was unable to find a place to create a signature in my profile, is that a supporting members feature only?

#1backyard mechanic
08-17-05, 09:13 PM
Welcome Long Hard Ride. Nice Car. Looks Like You Might Have A Air Ride Problem. Looks Like Your Ride Is Squatting A Lil Bit. The Rear Shocks Are Usually Air & Theres A Pump Under The Hood. Check It Out.

longhardride
08-17-05, 10:01 PM
Yes it does have an air ride problem...not sure what/where to look for pump. Where would the pump be located? Any tips on trouble shooting it?

fleet-wolfe
08-22-05, 07:00 PM
welcome there longhardride i am also a new member too the forums i just got me a 1989 fleetwood and man do i love it that seems like a pretty awsome model you have there if you wanna see pics of mine they are in the cadillac images under fleet-wolfe have a great day