: taillights not working and fuse keeps popping...



jaynjessie
07-20-05, 02:33 PM
Hi I have a 2000 Escalade and recently the taillights quit working. The fuse is blown and everytime we insert a new one and turn the ignition or manually turn on headlights....it POPS!!!!:hmm:

PLEASE HELP!!!!!:bonkers:

Thank you,
Jessie

99escalademan
07-20-05, 04:22 PM
I have a 99 and my right tailight is out.. I cant figure it out either, i have checked all the fuses and tried new bulbs.

nickc280
07-20-05, 04:37 PM
that sucks you have a short somewhere, did it just start happening?? did you do anything different??

jaynjessie
07-20-05, 04:52 PM
that sucks you have a short somewhere, did it just start happening?? did you do anything different??

No haven't done anything different...just happened out of no where!!! Took it to a friends shop and they wanted $500 (not including labor) :rant2:.....so wanted to see if any of you fine people have had any similar problems and how you went about fixing it...

jaynjessie
07-20-05, 05:01 PM
I have a 99 and my right tailight is out.. I cant figure it out either, i have checked all the fuses and tried new bulbs.

I've been trying to search for common problems...like maybe there is an electrical problem with these years...but was unable to find anything!!!! Sorry!!! But if I find anything that may help you......I'll let you know for sure!!!

99escalademan
07-20-05, 11:19 PM
Talked to the caddy dealer today. There was a similiar problem with trailblazers from 00, there was an upgrade pice from them.
I needed a new chip plate, where you plug all the bulbs in. There was alot of corrosion which made the short. Check your bulbs and see if they have a burnt appearnce on the back. Replacing all bulbs should work. If not the new part is 80$, but worth it since a ticket would be over 100$.

slimm44
07-21-05, 01:10 AM
Talked to the caddy dealer today. There was a similiar problem with trailblazers from 00, there was an upgrade pice from them.
I needed a new chip plate, where you plug all the bulbs in. There was alot of corrosion which made the short. Check your bulbs and see if they have a burnt appearnce on the back. Replacing all bulbs should work. If not the new part is 80$, but worth it since a ticket would be over 100$.

i needed a new taillight circuit board too for my 99 because of excess corrosion. i got one off ebay for like $25. not genuine GM, but it worked just as well.

dnyce617
07-21-05, 10:42 AM
I had the same thing on my 2000. The dealer replaced the circuit board under warranty at the time (2002.)