: oil temp issues



mchm3
07-12-05, 04:19 PM
do you guys have high oil temp problems mine gets to like 300 degrees and that damn sensor goes off like crazy i know i read somewhere that the temp gauge reads alot hotter than it should..... is there a fix for this or should i take it to the dealer 2 check it out

Florian
07-12-05, 04:21 PM
relax, take a deep breath, drive to your dealer with your 04 V and tell em you need to have the oil temp reflash....theyll know. There is indeed a fix...see cadillacfaq.com.

F

mchm3
07-12-05, 04:26 PM
does it matter i have headers

thebigjimsho
07-12-05, 04:27 PM
do you guys have high oil temp problems mine gets to like 300 degrees and that damn sensor goes off like crazy i know i read somewhere that the temp gauge reads alot hotter than it should..... is there a fix for this or should i take it to the dealer 2 check it outOn an '05??? I thought it was fixed by the mid-'04 cycle? I think it may be something else.

mchm3
07-12-05, 04:29 PM
ya mine is an 05 and it started a little after i got the headers put on

Florian
07-12-05, 04:32 PM
shit, you got trouble then. The 04s had a simple reflash reqd. The 05's had that taken care of. Is your water temp high too>? If so, run, dont walk to the dealer.

F

mchm3
07-12-05, 04:41 PM
nah everything else is normal except for the oil temp

RobzBLKV
07-12-05, 09:13 PM
That doesn't seem to make a lot of sense. Maybe the sensor was damaged during the header install? Did you get a computer tune with the headers? Maybe the tune inadvertently put the old oil temp software back in.

RocketV
07-13-05, 03:05 AM
Just so everyone knows, RobzBLKV is slower than mine.:coolgleam

BliTzer
07-13-05, 03:10 AM
Thats exactly what i mean. That is why i kept telling you guys " I need an Oil Cooler", & had it installed. My water & all other temps were normal too. Here in Phoenix it has been 105 to 113 daily, my oil temp was hitting 260 to 295 & it would not take long to hit those temps.
Since i installed the Greddy oil cooler im avg. around 229 & that makes me feel much more confident then having to glance at the damn oil temp every few minutes. I have two oil temp guages now as well, one i monitor outflow from cooler, the other that came as stock, i monitor two pressure gauges as well, one for oil since i have those intake/outake oil lines, the other is for fuel. I had fuse blow on that fuel booster that was installed with maggie & broke down on side of road, could not figure out wtf went wrong, esp since i could not check fuel pressure & no whistles or bells for when that happens.
Who ever else has that booster for Maggie i would check that fuse & make sure it is a tad higher or replace whole thing with higher volume fule pump with regulator, it is just a matter of time, that fuse will blow. Mine was in trunk, right side, under panel/carpet.

Also, don't worry about when it gets cold during winter, it comes with a remote switch to turn pump off at the oil filter so it will not circulate when you need those warmer temps. If i lived back in Florida or some place else not as hot i might not have gone thru with it.

later... BliTzer ;)

mchm3
07-13-05, 11:29 AM
well i dropped it off this morning at willimson cadillac.......well see what it is soon enough

Dreamin
07-14-05, 01:53 AM
Check (or have the dealer check) the wiring harness from the oil sensor to the connector going thru the firewall... my money is on the headers have melted the wires...

http://zeemr.home.comcast.net/u/Voil2.jpg

mchm3
07-20-05, 01:20 PM
well i took it to the dealer and the car wouldnt heat up they check it and said it was fine but my car still does the same thing the oil temp goes up to 320 but i noticed that when i turn off my ac it goes back to normal in like 5 seconds and when i turn it on again it goes back up:confused:

heavymetals
07-20-05, 01:49 PM
Are you talking about the pressure reading on the Message Center, or are you talking about the light on the dash?

These are controlled by TWO (2) different sensors in two different places.

One is at the rear of the manifold (Oil Pressure Sensor for the Message Center), and good luck getting that one out (if you have a maggie).

Dreamin
07-20-05, 04:26 PM
mchm3: I would not drive the car with this problem... you should take it back to the dealer... and go for a test drive with a service tech.

And the engine oil overheating sets a DTC code... they should pull the codes.. i think it sets P0195.

Heavymetals brings up a good point... do you see the large orange oil can flashing on the dash? Or are you only seeing the 320F on the DIC.

Dreamin
07-20-05, 04:28 PM
You are talking about the temp reading on the Message Center or are you talking about the light on the dash?

These are controlled by TWO (2) different sensors in two different places.

One is at the rear of the manifold (Oil Pressure Sensor for the Message Center), and good luck getting that one out (if you have a maggie).

Where are the oil Temp sensors?

heavymetals
07-20-05, 05:21 PM
check this thread:

http://www.cadillacforums.com/forums/showthread.php?t=45855

I posted pictures too!

Be prepared to remove the windshield wipers, assy and facia (the works) for a real good look though. This is for the OIL PRESSURE readout to the Message Center.

As far as the OIL TEMPERATURE sensor, that sensor is on the pan as shown.

This car has multiple sensors and some are redundant and give other warnings or indications.

Dave's V
07-20-05, 05:36 PM
Something doesn't sound right especially since the oil temp seems to drop to normal quickly when the AC is turned on. There is a problem, probably indicating.

I was driving my V hard coming out of Death Valley in 100 degree heat. AC was blowing, going 70mph in 6th on a 7% grade for miles and and the oil temp never went above the 210s.

mchm3
07-21-05, 12:37 PM
mchm3: I would not drive the car with this problem... you should take it back to the dealer... and go for a test drive with a service tech.

And the engine oil overheating sets a DTC code... they should pull the codes.. i think it sets P0195.

Heavymetals brings up a good point... do you see the large orange oil can flashing on the dash? Or are you only seeing the 320F on the DIC.its gets to 320 and then it starts flashing and making noise

heavymetals
07-21-05, 02:44 PM
On the message center don't you mean (temperature readout)?

Does anything come up on the DIC?

Have you pulled the dipstick when it read that?

Bad sensor is my bet (the one on the pan).

Take it to the dealer.