: 97 n* rough idle



fullserviceman
06-27-05, 10:16 AM
My 97 deville had 4 plugs changed to autolite before I bought it (he couldnt reach the other 4) and new wires. IMO this was a dumbt as ya can get. At any rate it has a vibration like a rough idle would this be a cause? and should I have all the plugs changed to the gm double platinum type?

mechanix
06-27-05, 01:04 PM
I wouldn't use Autolite or Motorcrap spark plugs in my rototiller! *lol* I run AC platinum in my N* and I like 'em. They are not as easy to gap as conventional plugs, but I believe the spark "snaps" across the electrodes a little more aggressively and produces a better ignition.

powerglide
06-27-05, 01:22 PM
try ACD DELCO plugs and wires.....its a logical spot to start. (No DTC codes right?)

You can remove the ignition coil bracket to make it easier to get to the plugs in the back....you can also easily remove the stut tower braces but you should'nt need to

Ranger
06-27-05, 01:26 PM
Bbob once mentioned about a Northstar that used Autolite plugs of the "correct" heat range for the engine. Turned out that is was not the correct heat range and burned a hole in the piston if I recall the story correctly. Stick with A/C Delco 41-950's.

fullserviceman
06-28-05, 01:06 AM
No trouble codes other than p420 and pzm 1520? if Irecall that correctly. Yeah I agree with ac delco plugs platinum or not. All of our trucks have them and my past cars had the double platinum with over 120k. on them. ?Not sure why the previous owner put the 4 autolites in . It had a skip due to a burnt wire but a new wire set cured that....I will attempt to change them tomorrow and report back... thanks