: 1996 northstar in 95 eldorado - Strange things happening!



dcdalton
10-28-03, 01:13 PM
Hi folks, Im brandy new here...been reading the forums for a couple of days & found the info quite useful. My new eldy is the 2nd one Ive owned, the first was an 85 that we swapped a buick 350 into due to a bad HT4100 (were there any good ones?) Anyways, to my current problems:

I recently bought a 95 eldorado that needed an engine & some tranny work. Found a 96 VIN Y northstar in a boneyard with 45k on it & dropped it in (oh that sounds so easy doesnt it?) & had my tranny shop install new shift solenoids & some kind of update kit. I had to put my old intake on it & swap over my knock sensor but besides that I saw no differences at all. I will say it runs like a champ but I have some very, VERY strange things happening & Im not sure if there is something I missed on the engine or if it has nothing to do with it.

Im getting a service engine soon light with 2 codes, I forget the numbers but the one said "Bad ECM" & the other said "PCM to ECM voltage problem", thats just the beginning. I took it for its maiden voyage last night & when I shut the car off the wipers DONT shut off, neither does the radio! Lastly about half way home (raining like wildfire) the info panel displayed "TRACTION DISABLED"....I have no clue what this means.

Just so you know Ive been a mechanic for many many moons but got out of it about 4 years ago (computer programmer now) so my knowledge of these newer computer driven vehicles is limited. Any and all help from you Caddy experts is more than welcome.

dcdalton
10-28-03, 02:21 PM
OK, I just found the section over at caddyinfo.com on self testing, ran it & this is what came up:

history codes:

P039 - torque convertor vcc engagement
P047 - IPC - PCM Data problem
P052 PCM Memory reset
P109 ?????????
I027 - PRND321 switch failure
I052 - keep alive memory error

current codes:

P090 TCC Brake switch input circuit problem
T067 brake light switch fault
T072 - serial data link fault
S044 - lift or dive signal fault

No ACP codes, No SIR codes

Now when I ran this before I did it with a snap-on scanner & it gave me the bad ECM code. With all of these codes happening in the self test I really have wonder if in fact it is bad or if something wasnt hooked back up during the swap that would cause this strangeness? Any thoughts??

elwesso
10-28-03, 08:13 PM
Ill tell you why.... 96 is OBDII, your 95 ECU is OBDI.....

Go get that 96 ECU and put it in..... It'll work......

There have been a lot of guys with ECU problems here reacently......

dcdalton
10-28-03, 08:34 PM
Well that would definately do it. ..... Now 1 more question, how is that 96 computer going to work with the rest of the car (non engine) & the PCM thats in it?????

elwesso
10-28-03, 08:49 PM
I dont think there's gonna be a problem..... If you can still get it, get the ECU and TCU (tranny control unit)... The TCU may not like the 96 ECU....

If it still does goofy things, then you may wanna grab the BCM also.....

dcdalton
10-28-03, 09:16 PM
well now we may have a problem. The deville I got the motor out of was already stripped of the computers & transmission....... OH freaking joy. BTW, wouldnt changing the TCU freak out the tranny (which still is the 95) ..... why do I get the feeling Im in for more fun than I expected? Also ... do these computers still have the PROMS in them that need to be changed? If so how the heck is that gonna work?

elwesso
10-28-03, 09:24 PM
I dont think it would freak out the tranny, since its the same tranny (i dont think they changed it for OBDII)..... But the ECU is looking at an OBDII TCU..... Not a 95, OBDI ECU..... It may or may not work, but Id pick up both, and make sure they are from the same car so that you dont get them mixed up......

Get on ebay, or check www.car-part.com and see what you can come up with.....

I dont think its gonna be that big of a deal..... Honestly, I think you just need to get a new computer(s) and you'll be golden.......

Couldnt tell you anything about PROMS........