: service engine light is on



bluelac96
10-27-03, 04:57 PM
ok, i just installed an k@n cone filter, on the end of my stock intake tube, i moved the air temp sensor and placedit onto the elbow and whatnot, a relativiley clean and professional installation, needless to say i drove around for a while and everything was peachy, then all of a sudden i felt a pop, then the car started to buck and run like shit, hesitating and stalling, the check engine light came on and i got a service emission systems message on the DIC. when the light turned off the car ran smooth as hell, then the light came back on and has been on ever since, i thought maybe it was the o2 sensors from all the extra air the engine is getting but im actually baffled, and concerned b/c im hoping i didnt mess anythign up b/c caddies arent the cheapest cars to fix, has anyone had the same problem? and info on how to fix this and what to do would be greatly accpeted.

thanks

elwesso
10-27-03, 06:07 PM
Sounds to me like you messed up the MAF..... Maybe.....

Do an OBD..... Tell us what codes come up......

Do that by pressing off/warmer at the same time, and telling us what codes come up........

bluelac96
10-27-03, 10:22 PM
ok i did the obd test and i got a bunch of numbers

pc 0113
pc 0101
pc 1111
pc 1520
pc 1599
then i got
no ipc
no sdm
no tcs
no acm
no rss
no pzm
no irc
then i got
rf 2560
then i got
pcm?

where can i go to look up these codes to figure the hell out whats wrong?

zonie77
10-27-03, 10:46 PM
I don't have a manual here but have you tried replacing the stock setup and seeing if it runs OK?

bluelac96
10-28-03, 12:13 AM
judging by the codes that i got i figured out the problem a P0101, and a P 0113, and a P 111 all indicate intake air temp sensor problems,when is installed the new intake setup i had to relocate the intake air temp sensor to the new pipe going into the intake, if im not mistaken those damn thing are real sensitive, i dropped that bitch on the ground when i pryed it loose from the stock intake box, i probably broke it and thats why my car is runnin like shit, good thing i work at and auto parts store, get the goods cheap! and good thing for this website i hope this is the problem and i can fix it

elwesso
10-28-03, 06:35 PM
To interprit the codes...... Simply goto the lounge and look in the HELPFUL CADDY LINKS thread...... There are a few websites that translate them.......!