: Northstar engine miss



rangatang
05-11-05, 08:48 AM
:bonkers: Hey there all of you die hard caddy lovers(just hacking on ya)I'm trying to keep a sense of humour but here is my delema:

I have a 94 Eldo that I have admired for years.It was the deal of a lifetime I thought.Car is a rocket on wheels and I love it or I would get rid of it but I bought it knowing it had a miss at idle.I have drove the car about 300 miles and the antifreeze doesn't drop a bit,no leaks and I have done a leakdown test which was fine.I did a compression test and found the #5 cyl. at 60 lbs.I never got any antifreeze out of the plug hole when I did the leakdown test so now I'm thinking it's a stuck valve.
Is this common on a Noerthstar?
I put a can of combustion chamber spray thru it and it runs a lot smoother but still has bad compression.
I bought the car from the original owner who is 80 years old and always had the car serviced at the dealer
The car has 160,000 miles on it and looks like new.I paid 1400 bucks for the car so I don't mind dropping some money into it.
The old fart that I bought the car from always has a smile on his face when he asks me how i'm doing with the car.I think he has it in his head that he put one over on me but even if I have to do a total rebuild on the engine I'm going to tell him it was just a faulty spark plug .That will get him spinning.
I will try to pinpoint the problem today...thanks:lildevil: :lildevil: :lildevil:

zonie77
05-11-05, 07:52 PM
Did you do a leakdown test and a compression test?

When you did the leakdown (pressurizing the cyls) did you hear air leaking somewhere? I would be looking at stuck rings first although that is pretty low compression. Did you squirt oil onto that cyl and run the test again to see what it did?

97BlueDeville
05-11-05, 08:38 PM
Spray Compressed Air into the Bad Cylinder, and look for bubbles in your Prezzure tank.. If bubbles bad Head Gasket. If no bubbles spray from 20W oil in the cylinder and check compression, if it goes up bad rings or broken ringlands.. If it does not go up might be a bad valve spring or bent valve but that's unlikely...

Good Luck..

Clint

rangatang
05-11-05, 08:40 PM
Thanks for your input zonie77.I did the compression test on all cyl. aqnd they were from 155 to 180 lb. except # 5 which was around 60.I put a rad tester on and pumped it up to 15lb and left it on overnight and it only went down 2 lb.I rolledthe engine over and nothing came out the plug hole.Thats what has me thinking it's a stuck valve.You are right tho,,I should have put some oil down the cyl. and did another comp.test.I'll do it again in a few days and see what I get.I'm thinking that the engine may have to come out...thanks again....Rangatang

ktills45
05-11-05, 08:55 PM
Spray Compressed Air into the Bad Cylinder, and look for bubbles in your Prezzure tank.. If bubbles bad Head Gasket. If no bubbles spray from 20W oil in the cylinder and check compression, if it goes up bad rings or broken ringlands.. If it does not go up might be a bad valve spring or bent valve but that's unlikely...

Good Luck..

Clint

Would you care to write a paper on this procedure, Hmmm? :D

rangatang
05-15-05, 10:42 AM
:bonkers: Hey there,thanks for the input.I have been checking the forums and I haven't found a problem with a single cyl having a valve problem.
I know that this car has been babied since new and I would have thought that all of the cyl.would have a cop. problem if 1 did.What I mean is ..All of the cyl. are between 170 and 180lb. except for #5 which is at 60.
I sprayed a whack of combustion chamber spray down the cyl.and let it sit for 3 days.Today I will start the car up and let it warm up,then I will put some more spray thru the throttle body.If no improvement I will put some oil down the cyl and if the comp. doesnt come up I will bring the cyl. to tdc ,hook up a differential comp. gauge and put 80lb. of air into the chamber.I will listen and if air comes out the exhaust then it is an exh. valve problem.If it comes back the intake then an intake valve problem.If it comes out the pcv valve its rings and I will lookor air in the antifreeze...Thanks again.. I will keep you posted...the Rang..

rangatang
05-29-05, 12:18 PM
:thumbsup: Got my 94 Eldo purring like a kitten.Found stuck rings in #5 cyl.Tried everything I could think of.Filled cyl. with combustion chamber spray and left for 3 or 4days but didn't help.I was about to pull engine and a friend of mine suggested filling the cyl. with diesel fuel.Left it for a week and I couldn't believe my luck but a least one of the rins came loose as I have 155lbs in the bad cyl. The rest are around 180.

Now for some stylin and profilin...in style.I'm givin her a good rod stretchin..Thanks to all..:cookoo: the rangatang

97BlueDeville
05-31-05, 11:03 AM
Diesel fuel.. Interesting...

Glad it's better...

Clint