: 93 fleetwood started tripping ........



bigmikelilmike
05-05-05, 10:31 AM
okay yesterday i was driving and my radio just cut off like 2 or 3 times while i was driving each time i just hit the power button and it came back on but my presets were gone ............then the ac control panel started flashing and counting down numbers like it was in dianostic mode wouldnt let me turn it off or anything then that stopped then lil while later mt digital speedometer went to like 100 mph then went back to 30 how fast i was really going it hasnt done it since ........i know caprices are known to have electrical problems with the digital dash but never heard of it in fleetwood ...........any ideas or suggestions any one had there caddy do this stuff ........thanks 4 any help

Adam
05-05-05, 12:37 PM
the only thing i could tell you is to try to pull your codes, if that doesnt work just take it to a dealer and have them look it over. good luck.

brougham
05-05-05, 12:47 PM
The codes are mainly just for engine problems. They probably aren't going to tell you stuff about strange electrical problems.

codewize
05-05-05, 04:16 PM
When the Climate control unit looses power it wil do that when you reconnect it. It's a self diag startup kind of thing. I would say that there is a short or loose connection in the dash somewhere. I'd be looking behind the radio.


Do you have any speed problems with the blower? Mine got stuck on low once and there was actually some connector just behind there burning.

bigmikelilmike
05-05-05, 08:05 PM
hey thanks for the advice guys that what i was gonna do pull the radio out and look at the connections .................where does the ac panel connect anything i should be checkin .....thanks again peace

bigmikelilmike
05-05-05, 08:06 PM
no speed problems with the blower ,,,,,thanks again