: Oil pump?



stoveguyy
10-12-13, 11:40 AM
I checked out 96 dev this summer with low oil pressure message. Told seller how to fix issue by overfilling oil. Am looking at another 97 dev today with same issue. Owner says car is nice but needs oil pump. I will keep my mouth shut when I look at it. Seller wants 500bo. Don't see low oil press issue very often.

MoistCabbage
10-12-13, 11:45 AM
Extremely unlikely that it's the pump.

Ranger
10-12-13, 11:58 AM
I agree.

Submariner409
10-12-13, 02:04 PM
You don't overfill a Northstar with a low oil pressure message until you have checked the oil pressure sending switch and its wiring for proper operation. Many, many threads and posts on this.

The second thing you check is proper torque/rotation sequence on the harmonic balancer bolt. That torque clamps the balancer hub to the oil pump drive sleeve and crankshaft snout (the oil pump is wrapped around the crank snout) - if the drive sleeve slips, no oil pressure. Also discussed at great length in here.

Here's the end result of sending switch failure .............. if the switch (on the top side of the filter adapter) looks greasy or is dripping oil from the body joint or electrical connector, that's your first suspect for an oil pressure message.

stoveguyy
10-13-13, 01:11 PM
Yes, at length. 96 did have lifter rattle at idle. Overfilling Fixed issue. My appt yesterday was cancelled. Have not seen the 97 yet

mjbrome
10-13-13, 11:31 PM
You don't overfill a Northstar with a low oil pressure message until you have checked the oil pressure sending switch and its wiring for proper operation. Many, many threads and posts on this.

The second thing you check is proper torque/rotation sequence on the harmonic balancer bolt. That torque clamps the balancer hub to the oil pump drive sleeve and crankshaft snout (the oil pump is wrapped around the crank snout) - if the drive sleeve slips, no oil pressure. Also discussed at great length in here.

Here's the end result of sending switch failure .............. if the switch (on the top side of the filter adapter) looks greasy or is dripping oil from the body joint or electrical connector, that's your first suspect for an oil pressure message.

Agreed. Got mine fired up today after hg repair. Harmonic balancer was loose and saying the same thing on the dash. Went away right away after tighted.

Good luck on the car! Sounds like a steel if that's all that is wrong.

stoveguyy
10-17-13, 11:17 AM
Update. Turns out cars are my neighbors that I talked about in may? Red dev has not moved for 1 yr? They got another white dev. Turns out both have issues now. But when the new CL ad said white dev had oil pump issues, I got interested again. Am curious. Seller emailed me yesterday and said red dev title is misplaced. White dev Is boyfriends who gave it to son and son is neglecting it and it is at sons house and title is also misplaced. Soap opera.