: 14 months = new battery



2004ctsv
04-16-05, 10:03 PM
Cadillac just installed a new battery in my car.

I had the V in for state inspection and asked them to check out the battery since it would lose charge in two days of sitting. The techs couldn't find anything wrong with electrical system or the old battery. They gave it a "deep" charge, patted me on my head and sent me home. The next night the battery was dead again. I called the service rep and he told me to call Cadillac Roadside Assistance and give his name. I called when I got home from work and the mobile truck arrived in 30 minutes.

After discussing the V, its problems, the Corsa, the FFV, the LS6 badge, old Chevelle SS (396/375), old Mustang GT's, street drag racing in the 60's etc, we put a new battery in the V.

I'll give it a chance but I have a hunch that this isn't the end of the problem.

Is there any feedback out there from V's with dying batteries?

Tony

Joey'sVee
04-17-05, 02:55 PM
keep us posted on this one...i'm curious

SoFlaCTS-V
04-17-05, 03:25 PM
Hi Guys! New memeber here. :thumbsup:

I had to reply to 2004ctsv's battery "issues"

After 27 days in the shop and 3 or so dead cranks in the morning, the dealer finally fixed my car.
After replacing the battery and hoping it was fixed thay finally traced it to the navigation/radio system. They had to replace the radio unit as they found a short in the battery causing a draw on the system. See if they checked this out. BTW, a month's lease reimbursement from Cadillac is on it's way.:thumbsup:

Let me know if you want more details!

SoFlaCTS-V

Joey'sVee
04-17-05, 04:27 PM
Wow it took a month???? That's a long time! :shocked2: (http://www.cadillacforums.com/forums/misc.php?do=getsmilies&wysiwyg=1&forumid=privatemessage#)

By the way....:welcome: (http://www.cadillacforums.com/forums/misc.php?do=getsmilies&wysiwyg=1&forumid=privatemessage#)

SoFlaCTS-V
04-17-05, 04:46 PM
Thanks Joey. :yup:

Total down time was 27 days. Most of the time was due to lack of parts. GM/AC Delco took so long getting the radio to me. Cadillac just kept saying there is no e.ta. on the parts. Brutal! BTW I also waited longer for a complete shifter unit. The darn thing came out while driving. Luckily I was able to put it back in to be avoid any trouble. :eek:

FYI - The servicing dealer refused to take a radio out of a new car he had, but the dealer I bought the car from offered to do it for me. The dealer I bough the car from is about 45 minutes from me, thats why I didn't go to them in the first place. To far.

SoFlaCTS-V

2004ctsv
04-20-05, 10:12 PM
Well, the battery was dead again tonight. That's not the worst though.

After a new battery last week, a trip of 250 miles to Penn State and back on Sunday, I parked the V in the garage.

I wanted to put it up on ramps and torque down the Corsa exhaust.

Insert the key - Turn to start - NOTHING
Reading 12.1 volts on the screen. Now I'm pissed so I call the service department manager at 8:30 pm. I left a message on his voicemail to call me tomorrow at work.

After the call, I got back in the car and turned the key for no other reason than to get madder. THE DAMNED THING STARTED RIGHT UP.

SoFla - I may have your electrical gremlin

Tony

SoFlaCTS-V
04-20-05, 10:24 PM
2004ctsv Tony:

Keep at it! Darn dealers cannot fix anything. :yawn:

According to them I never had a dead battery, just a drained battery every time, therefore the car needed to be jump started. But due to the drain it kept leaving me with no crank. So have they checked for a drain coming from the navigation/radio???? You never know.

My rep. at Cadillac customer care authorized a check to be sent to me equal to a month's lease payment. :) So, keep on them!

Let me know if you want local contact info. for my dealer, if your dealer wants to consult.

SoFlaCTS-V

Dennisscars
04-20-05, 10:43 PM
I had the same problem, on a post around here somewhere. Two things there are TSB's on, one is the console dimmer switch even though it's not on dome light it has to be only 85-90% other wise the module stays awake. Also I had another car in the garage that I set the Viper alarm. It constantly communicates with the clicker, something about RF signals to the tire sensors keeps waking the module up. There are some TSB's on CadillacFAQ. So now I set the dash dimmer to 50% and don't set the alarm in the other car and haven't had any problems. my .0126753 cents worth