: ignition switch



bravo366
04-14-05, 11:07 PM
Have a 96 sts that recently started stalling, just like you turned the key off while running. Dealer ran diagnostics and couldnt find anything wrong but they say it may be the ignition switch. Anyone ever replaced one or know how difficult it would be with the pass key?

therodman
04-15-05, 12:17 AM
I had one replaced a few months ago for about $200. Everyone I talked to said you have to be careful with a few sensitive parts for the air bag or you have to redo everything. The new ignition and an extra key is pretty close to $80 if I remember correctly so I didn't mind paying the $120 to get it done and which caem with a 12k mile or 12 month warranty.

Mine wasn't intemittent though, it just didn't do anything when I tried to start it one morning and the message center said check anti theft sytem. Before I changed the ignition I would do some more checking becaue I would suspect if it was the ignition shutting the car off you would receive the check anti theft sytem like myself. If you can, wait until a few others who have been here and know more comment, they'll give you some good advice and a possible route to find the problem.

I once had a car that would quit like while driving it, wouldn't start back up for a few minutes. It would turn over but wouldn't fire at all. After about 5 different garages and many hundreds of dollars it turned out to be the crankshaft sensor. Does you car turn over when it quits, if so, I doubt it's the ignition! I assume the N* has a crankshaft sensor and if so, I would tap it while it's running and see if you can get it to stall.

Good luck,

mcowden
04-15-05, 11:28 AM
That is a typical symptom of a failing crank position sensor. What else happens when the engine stalls? Dash lights go out? Does it act like you turned the ignition off? Any dash messages at all? Have you checked for codes yet? I assume the dealership/mechanic checked, but you never know. They seem to give those jobs to pretty much anyone who has ever changed their own oil these days.

bravo366
04-15-05, 01:39 PM
The dealership says they ran diagnostics, checked the battery and wiring, (whatever that includes) but couldnt find anything. No codes at all. When it died, I still had dash lights if I manually turned them on, power seats, windows, so I didnt think it was the battery. When I turned the key to start, I got nothing not even the warning lights that initially light up when the key is turned. The next day I tried to start it and after 5 or 6 tries, it started and ran fine. I took it to the dealership and the service manager said it did the same thing to him when he first tried to start it but started on the second try. Bottom line, they told me they couldnt find anything and recommended I keep driving it until it develops more of a pattern. That didnt make any sense to me, I dont want to be out driving in traffic wondering when the "pattern" will resume. Thanks for any suggestions guys.