: Engine Codes PC0300 & RF2560



JVF96STS
04-08-05, 06:23 PM
:banghead: Hello all! I'm new to the forum. My Service Engine Soon light was on and the following codes were detected: PC0300 & RF2560.

Does anyone have a manual to tell me what the codes mean? Thank in advance!

Joe

mcowden
04-08-05, 07:26 PM
You can always check codes here:

http://myweb.accessus.net/~090/dtcobd2.html

I know offhand that the PC0300 is "Misfire Detected," but I'm not sure about the other. Look it up and post again. Someone will be able to help you figure it out.

JVF96STS
04-08-05, 08:32 PM
Dude

I appreciate the quick response! Hope to contribute to the forums. Thank you.
:drinker

powerglide
04-10-05, 02:30 PM
You can always check codes here:

http://myweb.accessus.net/~090/dtcobd2.html

I know offhand that the PC0300 is "Misfire Detected," ......


LOL it seems everyone becomes all to familiar with the good ole P0300! LOL

I too am all too familiar with this code.

JVF96STS
04-10-05, 02:59 PM
Powerglide:

Is this something serious? All I did was reset the code to see if gets set again.

Thanks.
Joe

powerglide
04-10-05, 03:08 PM
welcome to the forum joe!

Dunno if its serious, it just means a misfire was detected. Could be ignition related, fuel delivery related....hard to say.

How's the car acting, idling rough, surging, (rpm jumping around)?

I've had it happen a bunch of times, I drove around with it for a while till I could get the info to fix it. Usually folks suspect the plug wires and plugs, then the ignition coils.

All of which are easy do it yourself fixes and parts aren;t that expensive.

But these are just guessses withouth knowing more about your problems. Could even be a loose battery cable, alternator, etc etc.

Did you search the forum (especially this Northstar section using words like p0300 or misfire? I have found so much help here, if you are a caddy owner this is must-visit site)

JVF96STS
04-10-05, 04:17 PM
I've had various "quirks" over the three years I've had the car. It's got 61000 miles on it now. In the past, the engine has shut off. More recently the idling RPMs were over 1000. However, that problem stopped.


Also, the car has a hard time starting at times. With the engine warm, I sometimes need to press the gas pedal to get it to kick over.

I searched the forum like you said and there seems to be numerous posts concerning the code. I'm going to read them over.

I love this site!