: 1998 STS - Dies at speed and won't restart sometimes.



jen98sts
08-26-13, 06:02 PM
I have a 98 STS. Was driving down the freeway and once I hit about 50mph it shifted a little hard then died. I pulled over and tried to restart it. It would just turn over but not fire. Then I pumped the gas pedal real fast while turning it over then it started. If it sits over night it will start rite up. After the initial start and a quick drive up to 50mph the same thing. The only way to start it is by pumping the gas pedal real fast while turning it over. Any suggestions???

rodnok01
08-26-13, 06:54 PM
Have you pulled codes? Goto Past Cadillac/Seville section andn there is a sticky on how to do it and look codes up.
Post codes and definitions. This post should have been in that forum anywho...

Ranger
08-26-13, 10:00 PM
Pumping the gas does absolutely nothing on a fuel injected car. The only thing you are doing is opening and closing the throttle plate real fast. Might want to check your fuel pressure and clean the TB.

mjbrome
10-13-13, 01:16 AM
Crank or cam sensor? My 02 suburban was doing the same thing and regrettably changed fuel pump and it was crankshaft position sensor. 8.1 big block baby! If I remember right when I was looking at parts for my 01 deville it showed two crank sensors (??) and one camshaft sensor. Don't know where the crankshaft sensors are but the camshaft sensor is on rear head, passenger side, below valve cover.

Submariner409
10-13-13, 12:45 PM
This thread has been dead for 2 months ........

CKP and CMP locator diagrams and pictures in my albums.