: RearView Mirror Temp/Compass wont display



praelade
08-16-13, 10:17 PM
I have a 2003 Escalade. The rearview mirror temp/compass display doesnt display anything. And yes I have tried the On/Off button. Is there a fix for this?

the cadillac man
08-16-13, 11:14 PM
I have a 2003 Escalade. The rearview mirror temp/compass display doesnt display anything. And yes I have tried the On/Off button. Is there a fix for this?

Check the fuses and the mirror harness

praelade
08-16-13, 11:57 PM
Which fuses? The Onstar, Airbag lights work. And it shows 2 green lights. I checked some fuses but maybe I got the wrong ones? The mirror harness looks good. No bent pins or anything...

the cadillac man
08-17-13, 12:07 AM
Which fuses? The Onstar, Airbag lights work. And it shows 2 green lights. I checked some fuses but maybe I got the wrong ones? The mirror harness looks good. No bent pins or anything...

Check all of them even the ones in the dash if all is good then the mirror will have to be replaced

Primetime1267
09-10-13, 06:01 PM
My mirror started flashing and not showing the temp. I bought a used one and it last about 4 months and it is now starting to flash and goes blank after awhile...

Sent from AutoGuide.com Free App (http://www.autoguide.com/mobile)

the cadillac man
09-10-13, 06:35 PM
My mirror started flashing and not showing the temp. I bought a used one and it last about 4 months and it is now starting to flash and goes blank after awhile...

Sent from AutoGuide.com Free App (http://www.autoguide.com/mobile)

Sounds like the harness connection is bad