: high performance accel ignition coil nightmare



nyshark
08-11-13, 02:19 PM
I wanted to put a new distributor cap and Rotor in my 81 sedan deville so I Saw that for just $20 more (cost of 5 gallons of gas in NYC) I could install this state of the art h
Accel high performance ignition coil . Well all went perfect for about 15 miles of driving Then the Engine became possessed I mean it started to really rev up big time then slow down big time then rev and rev and then just shut off lol , I Put back in the original factory coil and ahhhhhhh the exorcist was performed The car idled so smooth you can balance a nickel on its side on the hood at idle .I been reading about a lot of bad experiences people have had putting in these high performance ignition coils seems there may be a lot more involved than just simply putting a new coil in ,Some say re-gapping to .045 from factory .060 is first step and the list goes on and on

csbuckn
08-11-13, 05:51 PM
Same thing happened to me. Mine lasted about 40 minutes, just enough to get me to the bad part of town and leave me stranded. Luckily I had someone following me. Put the old coil back in and drove off.

carnut
08-11-13, 05:51 PM
I presume you transferred the coil ground plate from the old coil to under the new coil?

csbuckn
08-11-13, 08:01 PM
I did but I'd bet the ground plate couldnt keep up with the high output coil.

nyshark
08-12-13, 01:36 PM
I was almost tempted to get mine out on highway but opted to just tool around local streets I am glad i chose the latter sorry to hear you had a nightmare situation with that accel high performance coil .

nyshark
08-16-13, 06:19 PM
I tried installing a high performance accel coil , and the car behaved like it was possesed i put the old original coil back and it ran perfect but now after 200 miles or so it has begun to accelerate for no reason the engine just revs up i keep it in neutral at lights I am open to any ideas i respect your input thank you i am willing to change anything that may be causing this so fire away thanks

csbuckn
08-17-13, 04:03 AM
I dont think your problem is related to the coil but I cant think of what it could be. Sticky throttle return spring?

nyshark
08-17-13, 12:41 PM
The spring is not the best actually I will replace it I think the high output coil may have fried the module in the distributer I will go buy a few sensors today the car is well well worth it i will invest in A TPS and ICG module replace the throttle spring The car was never really pushed at all in last 20 years I have been pushing it a little to hard I just cannot get enough kicks at seeing the look on peoples faces when they see a 34 yr old car blow past them at 90 mph with windows up AC pumping lol .The high output coil was game changer . now at idle it just begins to rev up pretty high rpms I pop hood and watch it it is most likely a electronic snafu caused by excessive voltage to sensors from high output coil that is when it all began I will even be willing to put a new ECM in .the car is just so much fun.

drmenard
08-17-13, 07:16 PM
I had a accel coil last about 3K miles.. When I called them on it , they said it was out of there 30 min. warrantee.

nyshark
08-18-13, 03:23 PM
Advance auto parts was very good about returning the cash i paid , the counter man said they are made in china and get a lot of returns on the coils that are sold he was not surprised this coil started this current problem Only AC delco from now on

CadillacPimpinNOLA
08-18-13, 05:51 PM
theres other better quality brands to choose from, never was a fan of accel...try MSD, mallory, petronix

nyshark
08-20-13, 09:35 AM
Had an old timer look into my dilemma and he concluded it was just a coincidence that the Idle air motor failed shortly after I installed the high output coil . The idle air in this year 1981 is engaged at idles at start up temperature up to 190 degrees then it is disengaged it is also if there is a sudden demand on the engine during normal driving as a sluggish AC compressor knocking the timing off slightly the idle air will push throttle to accelerate engine rpm to keep the car from staling until the ECM can correctly maintain the ignition idle . also it is the part that engages when you put the car in cruise control ( i never use cruise control no matter how new or old a vehicle I am operating , So I said to myself Hey self just disconnect it and see how it idles . to my surprise I just had to adjust the screw to get the correct RPM very slightly , 100 miles city stop and go driving with AC on and not a stall , but now I want that amazing power I had when i first installed the high performance coil , so i am going to put a new high output coil in again I have a new ICM in and new rotor and cap new high output wires and plugs .I must say it was really kicking ass until the idle air motor started to show its age . I have no problem pushing the accelerator to start my car and slightly rev it until 190 or so degrees before driving . I will post how things turned out thank you I am a simple man i want a car that cars pretty fast without having to floor it and stops quickly , lol the high output coil was accelerating to 50 mph with hardly a push on the gas and i could feel the longer sparking burning every bit of gas in chamber .

nyshark
08-24-13, 11:42 AM
:yup: I have the defective Idle air motor disconnected and installed a high output coil , Let me say I am very happy the way it is driving Much better gas mileage and tremendous acceleration especially from 50 mph to 90 has real get up and go , the only thing that has changed since removing the idle air motor that was making the car run like crap , is first start up of day I have to keep slight pressure to keep the idle up slightly for about 3 minutes (timed it ) after it reaches about 190 degrees the engine purrs like a tiger . Thank you for all the help everyone on this board great bunch of people.

----------

I noticed at the last minute on that ground plate that there is a clear plastic laminate on it i caught it because i was giving it a scuff with a piece of steel wool that and the ground on the coil when I noticed plastic peeling off , , but all in all I put a new MSD coil high output matches the cap and rotor and wires all red now good luck . thanks

----------


I did but I'd bet the ground plate couldnt keep up with the high output coil.
I noticed at the last minute on that ground plate that there is a clear plastic laminate on it i caught it because i was giving it a scuff with a piece of steel wool that and the ground on the coil when I noticed plastic peeling off , , but all in all I put a new MSD coil high output matches the cap and rotor and wires all red now good luck . thanks