: A few questions from the new fleetwood owner...



Reverend Hearse
08-11-13, 05:33 AM
Traveled to st louis last week for a 95 fleet . Tow package car, 175k . Got a good deal and brought it home, it cleaned up quite nicely . I have a few questions..

The previous owner said the car needs a power steering pressure switch. Would that cause the car to have stumble issues when doing low idle turns ?

When i take off theres a definite hesitation and i must push more into the pedal past it... Wheres a good place to start a diagnosis?

Is the tow package 3.73 rear a limited slip , requiring a special fluid?

Reverend Hearse
08-12-13, 08:19 PM
alrighty.... or not ...... off to find factory manuals....

jayoldschool
08-12-13, 08:50 PM
Power steering pressure switch may cause that low speed stumble on turns. Unplug it to find out.

Hesitation is usually ignition. Start with coil wire, then plugs, then ICM, then wires. Then start to think opti.

Tow pack is 3.23, non posi. No additive. No 94-96 Fleetwoods got posi.

Reverend Hearse
08-12-13, 11:42 PM
what will unplugging it do? send it to full assist?

Gman1023
08-20-13, 09:21 PM
Wrong again. 94-96 tow pack has 3.42.

carnut
08-22-13, 04:47 PM
The pressure switch raises the curb idle slightly when turning sharp to park. Its probably not doing that. Unplug it and find out!

Reverend Hearse
08-22-13, 11:43 PM
Hell I can't even see the switch ..... It is back to stumbling again.... Kind of irritating . It does in traffic the other day . Started right back up . I can't find anyone with a OBD 1 scanner . The check engine light comes and goes ...

jayoldschool
08-23-13, 02:15 PM
You have an OBD1 scanner, it's built into your car. See the FAQ sticky for how to access the data through your HVAC head. I don't have a 94-96 anymore, but I seem to recall that the steering assist connector just plugs into the top of the steering box. Driver's side frame rail, under the air intake tubing...

Reverend Hearse
08-24-13, 08:08 PM
I got code 13 oxygen sensor circuit fault . When doing the diag , I get 111 instead of a actual voltage , which I assume means there's ashorT , possibly a bad o2 sensor??

Reverend Hearse
08-29-13, 12:14 AM
I need a idea... I notice tonight I have no brake or turn lights . All other lights function fine. A fuse diagram would be most helpful ....

jayoldschool
08-29-13, 05:46 PM
Fuse diagram is on the sticker on the back of the fuse panel cover. Driver's side door jam, end of the dash. There are more fuses in the AUX fuse fox under the hood (with their own diagram on the lid bottom).

carnut
08-29-13, 06:58 PM
The brake and turn lights being inop should be a new thread.

Reverend Hearse
08-29-13, 09:02 PM
Fuse diagram is on the sticker on the back of the fuse panel cover. Driver's side door jam, end of the dash. There are more fuses in the AUX fuse fox under the hood (with their own diagram on the lid bottom).

theres no lid , however after pulling all of them , i found the one for the lights , when replaced, it blows again... off to find out why...


carnut, i grouped it here with the general issues im having with this leftover junk car , didnt see a reason for a new thread, sorry...