: 2001 Catera Leveling light blinking



BossLady
08-05-13, 03:18 PM
I recently rear ended another vehicle at low speeds and I had to replace the radiator. Ever since I replaced it my leveling light will be on steady, and then start blinking consistently while I drive. I read somewhere that there is a hose that connects from the shocks somewhere. I did find one hose under the hood that isn't connected, looks like it's coming from under the car, on the passengers side. Does anyone know where I should start looking to fix this problem? Are there some wiring diagrams or something I can look at to see where this un connected hose should go? I'll try to post pictures of the hose I'm talking about. It doesn't seem to affect the way the vehicle drives at all, would like to fix before I attempt to sell it.

BossLady
08-05-13, 05:09 PM
Here are some photos of this hose. Tried to get different angles of it.

133185 133193 133201133209

kaustein
08-05-13, 08:19 PM
You might have some broken coil springs. Happened to mine. They broke in the tray that they sit in and were hard to see, but if you lift the car then you can see them. I'd take out the bulb.

98Catera_2010
08-05-13, 09:49 PM
Last week found out I have the same issue but only because my shocks need replacing. When i start the car its not on, the first bump i hit it starts to flash and doesn't go off because its trying to pump back end to spec height but can't with the worn shock.

kaustein
08-06-13, 12:07 AM
Last week found out I have the same issue but only because my shocks need replacing. When i start the car its not on, the first bump i hit it starts to flash and doesn't go off because its trying to pump back end to spec height but can't with the worn shock.

Check your springs too.

98Catera_2010
08-06-13, 08:04 AM
Ya i will when down there. But not suspecting because they were replaced a year or so ago as they were cracked like u mentioned right at the last coil.

retho78
08-06-13, 05:47 PM
I think that hose connects to the air pump.

BossLady
08-06-13, 06:18 PM
Last week found out I have the same issue but only because my shocks need replacing. When i start the car its not on, the first bump i hit it starts to flash and doesn't go off because its trying to pump back end to spec height but can't with the worn shock. Mine does the same thing, I don't think it's a broken coil, I think it has something to do with that hose. Where is the air pump? I need a diagram or something to help me out.

kaustein
08-06-13, 09:35 PM
I believe the pump is under the rear seat.

98Catera_2010
08-07-13, 09:10 AM
Im pretty sure the compressor for the shocks is mounted in the front, passenger side under the front bumper. Pretty sure me and my father-inlaw have un installed one off a parts car for his 98. I will ask him to confirm as him and i have become very familiar with these cars and do all our own work. He just picked up another Catera at the auction for 400. Had a dead battery and seized e brake so it was sold in the scrap, got it home put battery on it and un seized the brakes and she started right up and drives. Only 99000 kms . But were doin surgery on it to look at the engines guts make sure everything is fine and do new belt , pulleys all that stuff since its Prolly never been done yet with only 99000kms for a 98.

98Catera_2010
08-08-13, 01:51 PM
Maybe its different for a 2001 that Im not sure. As i have owned only 98's

retho78
08-11-13, 03:13 PM
Yes, behind the front bumper by passenger side for 97 to 01.