: Quick Question



Yaemish
03-13-05, 02:44 PM
I have a 96 Eldorado and today i went to change the coolant. I disconnect what I thought was the lower coolant hose that was at the bottom right running from something just in front of the radiator that looked like it was connected. A little oil came out so I put the hose back on and topped off my oil. There is no way I messaed anything up is there?

zonie77
03-13-05, 03:22 PM
The thing in front of the radiator is the AC condensor. Was it pressurized?

THe radiator hose is about 1 1/2 inches in diameter and squeezeable rubber.

mcowden
03-13-05, 03:38 PM
Sounds like the transmission oil cooler. What color was it? Reddish means it was transmission fluid and you will be just fine. Just make sure the hoses connected to the cooler are tight.

Yaemish
03-13-05, 05:57 PM
The thing in front of the radiator is the AC condensor. Was it pressurized?

THe radiator hose is about 1 1/2 inches in diameter and squeezeable rubber.

I think that was it. Did I mess it up?

zonie77
03-13-05, 06:53 PM
What color was the oil? Red or yellow?

Yaemish
03-13-05, 09:19 PM
yellow

zonie77
03-14-05, 10:12 AM
Was the AC working before. If it was there should have been a lot of pressure. If there wasn't much then the freon had leaked out previously. You didn't do any damage. You could have been hurt if it was full though.

Yaemish
03-14-05, 11:17 AM
I haven't really been using the AC because its been so cold. I only lost a few ounces and then it stopped dripping.

mcowden
03-14-05, 02:04 PM
There shouldn't be any oil in the condenser, though, especially not several ounces of it. With the lack of pressure I'd say that wasn't the condenser that got drained. If the system was low on pressure, you would see that the AC is always off and there would be a code set for it. I don't know what other oil would have been in that area other than the trans. oil cooler, but that should have been reddish in color. It could have been yellow- or brown-ish if it hasn't been changed for a while. I didn't think there was an engine oil cooler, but maybe I'm wrong about that or the car has a towing package installed. Either way, check the fluids, top off whatever is low, make sure all the connections down there are nice and tight and nothing is leaking, drive it and forget it. If you start hearing funny sounds when the AC compressor runs or it says the system is low, that will need to be checked, but I wouldn't worry about it too much.

You know, the ABS brake pump is down there, but I didn't think it had any drain type plugs or rubber hoses on it. Don't think there are any power steering lines down there. Are you talking about on the driver side, as in somewhere beneath the air filter box and PCM?