: starting problem



ryderrich
03-13-05, 03:45 AM
please help, 93 deville 4.6 n star.
runs great but when shut down for periods of time need to crank longer hard starting. smell fuel and have noticed no pressure to rail. pump pressures within limits and previous owner had just changed out pump. no visable fuel leaks. thanks to anyone for helpful advice on what to look at next.

Spyder
03-13-05, 07:17 AM
Check the fpr...fuel pressure regulator...take off the intake cover and turn the key to on...do NOT START THE CAR! as it will be unthrottled on a '93 or '94...check the fpr for any leakage over a couple of minutes... ...The fpr is the little thing that looks kinda like an inline aluminum fuel filter in the (facing the car from the front) upper right corner of the intake...if any fuel drips out of it or shows up, it needs to be replaced...many posts on this, search for it and there's lots of info... good luck!

Ranger
03-13-05, 07:23 PM
Wait a minute. '93 Deville? Northstar? '93 Deville had a 4.9. Follow Spyders advice except that there is no cover to remove. FPR will be mounted on the fuel rail and will have a vacuum hose attatched to it. You can pull the vacuum hose with the engine running on that engine and look for fuel leaking from the nipple as Spyder advised.

ryderrich
03-15-05, 09:33 AM
thanks to you both, yes the fpr was leaking badly. and I was tired and stressed when i input the deville it is a seville. now i have noticed the hoses on the fuel line are hard and brittle so i guess the next move while its apart is to replace the injector seals and the hoses conecting them together. again thanks a million. Rich