: Wiper Time delay not working properly



Jeppi94
07-31-13, 08:21 AM
Hello once again forum!

I was out driving my brougham while it slowly started to rain. First of all. If i pull the wiper slider to the left (DE MIST) they wont come up all the way and make a sweep. Though i can clearly see that the wiper motor is working and goes arround, but it seems like there's a slip somewhere in the joints. Next problem, it is extremely hard to get the wipers to work in time delay mode, they have only worke in delay mode one single time and that was after switching between mid and delay several times. most of the times when i put it in time delay mode they just stuck one third up the windscreen. Only mode that really works is mid speed which is way too fast if it's not pouring down. Anyone got any clues?

outsider
07-31-13, 08:33 AM
it's very common for wiper problems on these cars. I believe the major thing that goes out is the control board. I believe that would explain your symptoms of the delay not working well, although I think it can also cause the wipers to not shut off when you turn them off.

As for the slipping you may want to check the connection from the wiper motor to the arms?

Jeppi94
07-31-13, 08:40 AM
Yes i will have a look on the motor connection, i tried when i examined the wiper arms but it was very hard to get a wrench on the nut that connects the motor the the arm, have to try again with a smaller one. And you say the control board, is there any replacement boards i can get or is it possible to take it out and go through it?

Cadillac Giovanni
07-31-13, 08:47 AM
I got complete replacement switch assemblies from auto zone back in the day. They were re-manufactured, but they worked well. I recall them being about 35 bucks. You might try ebay, the prices will vary, though.

Jeppi94
07-31-13, 08:50 AM
sounds interesting, i live in Sweden though and those cars are quite raaare here and so are parts to them. Do you know if Rockauto or any other website that do ship OUTSIDE USA got such assamblies as you mentioned? :)

sven914
07-31-13, 01:07 PM
Rock auto has the switch, but nothing else. I don't know here you would find the circuit board or a new motor (USA Parts Supply (http://www.usapartssupply.com/index.php) has rebuilt wiper motors, but they only ship domestically).

I'm having almost the exact same issue with my car, where the wipers only work in MED or HI, and I can almost assure you that the switch isn't the problem. The two most likely causes are an open in the shunt field (internal to the wiper motor) or a broken lead wire, which is the grey wire coming from the black inline-three-way connector near the wiper motor. If neither of those fix the issue, then either the switch is faulty, or the circuit board is dead.

mitch2264
08-01-13, 09:47 AM
Hey guys, not sure if this will help or not, but on the 88-98 GM trucks they are plauged with bad solder joints on the wiper circuit board. I own a 97 GMC and it has had some funky issues with the wipers. I have cut and pasted a link to one my favorite GM truck forums that goes into how to fix the board wby resoldering the joints. You may want to examine your board and see if you have any suspect solder joints.
http://www.chevytalk.org/fusionbb/showtopic.php?tid/249096

Not saying this is the cause, but may be worth investigating.

Good luck!

Mitch

outsider
08-01-13, 10:07 AM
cool! Thanks for the info. I never would have thought of the solder cracking.

Jeppi94
08-01-13, 12:53 PM
Thx a lot for that info!! i will be investigating that at at once.