: My CD Player isn't working...



JamesC
07-30-13, 10:42 PM
1993 Cadillac Fleetwood Brougham and the CD player stopped working. Pretty sure there isn't a CD in there from the looks of it, but it refuses to accept a CD. It won't take it in. The tape deck works fine, though I think it may need to be cleaned.

Any ideas or troubleshooting?

Edit: I forgot to add it is the stock system.

nebulosity
07-31-13, 12:04 AM
*looks around* ... I don't see anyone replying yet, so I thought I'd google around. It seems to be a common issue in car stereos, although I've never experienced it. It's only happened in our PS3, but that's because the gearing mechanism on the inside is messed up. :/ We have to take the PS3 apart and correctly position the gears again to get it to work.

Is this a stock or aftermarket stereo? Looks like you can try a couple things (none of these are cadillac though).

+ Press and hold the eject button for several seconds,
+ One person disconnected and reconnected the battery to reset the system,
+ In another case it seems like damage is another cause, but I'm not sure exactly how you'd diagnose that

http://answers.yahoo.com/question/index?qid=20101008185756AAFuGPE
http://www.lxforums.com/board/f62/cd-player-suddenly-wont-take-disk-263579/
http://www.toyotaownersclub.com/forums/topic/99885-cd-player-wont-accept-discs/

Wish I could help more. :( I hope other people reply with good answers. Good luck figuring it out.

JamesC
07-31-13, 02:12 AM
Thanks I'll look into those links better tomorrow. Thanks still!

JamesC
08-01-13, 08:35 PM
Well nothing seemed to work sadly. I tried. Now another issue came up on another note (dealing with after an oil change and system not resetting right) shouldn't change subjects in the middle of this thread. Don't want to get into trouble.

nebulosity
08-01-13, 09:30 PM
Well nothing seemed to work sadly. I tried. Now another issue came up on another note (dealing with after an oil change and system not resetting right) shouldn't change subjects in the middle of this thread. Don't want to get into trouble.

Is it an aftermarket stereo? What's the other issue that came up?

JamesC
08-01-13, 09:44 PM
Is it an aftermarket stereo? What's the other issue that came up?

No it's all factory.

Did an oil change on Saturday and yesterday afternoon on the way home from work the "Change Oil" light came on. I thought I reset it, but apparently not. I reset the system as the manual says (turn ignition to "on" and depress the accelerator 3 times within 5 seconds to reset) I tried this several times and so did a tech. at a dealer I took it too. I've even disconnected the negative on the battery for a little bit to try and reset the system and nothing. "Change Oil" light still shows when running. They told me since it's not resetting it might be a wiring or computer issue which they said for $50 to $100 they can try and diagnose it, plus repair costs if I choose (though funds are tight right now)... I'd love to figure out what's the problem because having the light always on is annoying and just knowing that something little is "wrong" with it - even if not major - also annoys me >.<

nebulosity
08-01-13, 10:04 PM
No it's all factory.

Did an oil change on Saturday and yesterday afternoon on the way home from work the "Change Oil" light came on. I thought I reset it, but apparently not. I reset the system as the manual says (turn ignition to "on" and depress the accelerator 3 times within 5 seconds to reset) I tried this several times and so did a tech. at a dealer I took it too. I've even disconnected the negative on the battery for a little bit to try and reset the system and nothing. "Change Oil" light still shows when running. They told me since it's not resetting it might be a wiring or computer issue which they said for $50 to $100 they can try and diagnose it, plus repair costs if I choose (though funds are tight right now)... I'd love to figure out what's the problem because having the light always on is annoying and just knowing that something little is "wrong" with it - even if not major - also annoys me >.<

Yeah, it would totally bug me too. :(

JamesC
08-01-13, 10:24 PM
Yeah, it would totally bug me too. :(

It really does. I guess I'll just have to deal with it for now until I get a little extra money or somehow fix it myself it that's even possible, but I have to find out what exactly is going on first.

brougham
08-01-13, 10:38 PM
Those CD players get problems with age. Try to find a repair shop that can fix it. There's not much use getting a used one because unless it's already been repaired at some point before too it mightnot be much better then what you already have.

Cadillac Giovanni
08-02-13, 12:22 AM
If your dead set on keeping you dash stock, your only option is to try and find a repair shop or find a refurbished unit to swap it out with. Both are iffy propositions. If you're okay with a replacement, can I recommend a Kenwood DPX500? Just put one in my 95 Fleetwood after doing a ton of research and it's a great fit. Looks nice and sounds even better. Got pictures in the thread I made about it.

http://www.cadillacforums.com/forums/rwd-19xx-1984-deville-fleetwood-1985/332730-new-stereo-95-fleetwood.html

nebulosity
08-02-13, 03:37 AM
If your dead set on keeping you dash stock, your only option is to try and find a repair shop or find a refurbished unit to swap it out with. Both are iffy propositions. If you're okay with a replacement, can I recommend a Kenwood DPX500? Just put one in my 95 Fleetwood after doing a ton of research and it's a great fit. Looks nice and sounds even better. Got pictures in the thread I made about it.

http://www.cadillacforums.com/forums/rwd-19xx-1984-deville-fleetwood-1985/332730-new-stereo-95-fleetwood.html

Nice!!! :D