: Please Help!! Radio / DVD Wiring Nightmare...



Kingdombuilder
07-30-13, 06:18 PM
I bought a 2007 Escalade from a dealership in OH. After I have had it for a few months I found out that the original owner tried to mod the DVD player and Radio. I took it to Dukes here in Flint, MI and they informed me of the problem. They even showed me the mess that was left in it. It seems as they tried to mod a external wiring harness to be able to display to four head rest TV's. I would imagine that they even tried to mod the DVD player to play regular DVD's. There was wires coming out of the back of the radio that was not suppose to be there and I seem a ribbon cable that they tried to hack into for what ever reason or another. What I need help with is... I want to know if anyone knows where this mod maybe posted so that I can take a look as to what was damaged so that I can replace it with OEM parts. I will be able to grab a radio off of Ebay but the rest of what is damaged I'm still unsure. I will have to open it back up to see what all the wiring that was damaged so that I can take inventory as to what to replace.

If anyone knows of any posted mods online for this type of hack please post a link or give me some information as to how I can see what the process was and how I can revert it. Now I have trouble with the radio abd the Nav. The radio sometimes will not come on unless I shut the car down and start it back up again. the Nav goes in and out sometimes. Now I'm starting to see few other issues.

Any help would be greatly appreciated!

Cadillac Cust Svc
07-31-13, 05:22 PM
I bought a 2007 Escalade from a dealership in OH. After I have had it for a few months I found out that the original owner tried to mod the DVD player and Radio. I took it to Dukes here in Flint, MI and they informed me of the problem. They even showed me the mess that was left in it. It seems as they tried to mod a external wiring harness to be able to display to four head rest TV's. I would imagine that they even tried to mod the DVD player to play regular DVD's. There was wires coming out of the back of the radio that was not suppose to be there and I seem a ribbon cable that they tried to hack into for what ever reason or another. What I need help with is... I want to know if anyone knows where this mod maybe posted so that I can take a look as to what was damaged so that I can replace it with OEM parts. I will be able to grab a radio off of Ebay but the rest of what is damaged I'm still unsure. I will have to open it back up to see what all the wiring that was damaged so that I can take inventory as to what to replace.

If anyone knows of any posted mods online for this type of hack please post a link or give me some information as to how I can see what the process was and how I can revert it. Now I have trouble with the radio abd the Nav. The radio sometimes will not come on unless I shut the car down and start it back up again. the Nav goes in and out sometimes. Now I'm starting to see few other issues.

Any help would be greatly appreciated!

Hello,

I am sorry to hear that you are experiencing an issue with your vehicle's radio and navigation system. We would like to look into this concern. Private message if we can be of assistance.

Regards,

Jennifer T. (Assisting Laura)
GM Customer Care

Kingdombuilder
05-23-16, 01:01 PM
Ok So I finally got around to troubleshooting this issue. I want to say first off is that the owner of this vehicle before was trying to tap into the video ribbon inside the radio to hack the factory head unit to show video out to all the headrest monitors. I took out all the after market wiring for the Visuallogic install along with the modules. After doing so the electrical problems in the truck has gotten a lot better.

However there are still a couple of intermittent issues:
1. Sometimes the when putting the truck in park the doors does not unlock, and the lock / unlock button does not work. In order to get it to work when this happens I have to cycle the fold function on the side mirrors. once the mirrors fold in and out by hitting the buttons then the door lock buttons start to work again. Very strange.

2. Backup Parking Assist is not working where the corresponding button light is on all the time. The backup camera picture on the head unit says that it is unable to show the distance bars. I think that this is just an issue with the backup sensors though.

3. The rear unit of the back seat passengers seems to work, but there is no display on the screen although there is a back light to it. The buttons seem to function sometimes and when they do not if I hit the side of the console then it will start to work again. Iḿ assuming the unit needs to be replaced.

For the most part these are the current problems after removing the whole visualogic system. I left the monitors in the headrest but they are not connected to anything.

Any help would be greatly appreciated!!

aharper00
05-27-16, 11:44 AM
That's some crazy stuff. I remember seeing a thread on here about the ribbon. The goal is to allow your cell phone to operate from within the stereo screen. Not gonna lie... love the idea of this because I'd like to have Pandora controls or Waze on the screen. I don't have built in rear entertainment, though, so it would take a little extra work. That extra work may have been going on in your truck, too.

No clue on item 1... bermuda triangle stuff there. On item 2, I don't know why the light would be on but I don't think your year has distance bars. Mine doesn't... 2008. Item 3 does sound like a replacement unit but tough to say because you mention the multiple outs behind the radio. Swap left to right to see if you get the same behavior... easy way to see if it needs replaced. It will also tell you if you need to chase the wires to find something else messed up.