: Aux water pump replaced - then the heater control valve goes?



LCF
07-29-13, 05:13 PM
I'm just asking if it sounds right to you all that after they charge me $600 for a new aux water pump, the coolant pours out because now it needs a new HCV ($350) and they suggest I do the whole system ($750). Does it go like that? The "new pump pressure busts the HCV." If so, ok. If not, please advise.

MoistCabbage
07-29-13, 08:33 PM
The entire system is under pressure when hot, regardless if weather or not the pump is on or not. The pump had nothing to do with the valve failing, but the reason is irrelevant. If it's broke, it's broke.

LCF
07-30-13, 10:56 AM
I just wondered if my aux water pump was the problem in the first place. A bad coincidence! Thanks very much for your response. I've had 2 Cateras - this 2000 only has 40,000 mi on it. I love them.

JohnJJO
07-31-13, 03:01 PM
In my case I don't know for sure. I got over heat while driving, my radiator cracked due to this ,after my search I found fuse blowen 15amp under steering wheel(fuse not named) and my pump stop working. I went to junk to get pump, replaced pump, fuse and glued radiator it was working for a year until pump quit, I opened my pump, remove all shaving from brushes, cleaned very good with electric spray cleaner, put everything together, now its year pass and it just fine.

elvin315
07-31-13, 08:51 PM
In my case I don't know for sure. I got over heat while driving, my radiator cracked due to this ,after my search I found fuse blowen 15amp under steering wheel(fuse not named) and my pump stop working. I went to junk to get pump, replaced pump, fuse and glued radiator it was working for a year until pump quit, I opened my pump, remove all shaving from brushes, cleaned very good with electric spray cleaner, put everything together, now its year pass and it just fine.

What shavings?

JohnJJO
08-01-13, 07:17 PM
Metall shaving from brushes inside of pump motor. Over time they grind down and quit passing electronic connection and making motor stop working, in my case they didn't grind alway to condition where they need to be replace. Basically pump was not working and working very slow or in normal speed only when was wiggling it. Its happens at my ex-girlfriend house that 150miles way from home where actually my job as well, I had to go to work next day and pump quit same day I had to leave, auto parts stores didnt had pump for sale, only for order that would took 3 days and cost was over $140... So I was lucky to came up with this idea to fix motor, it was pain in ass to put all back togather but I took my time and did it. Over a year pass and pump still work just fine.